We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Raid 0 - Not booting windows + Errors!


DaleF
Resolved

Likes # 0

Hi,

I am currently trying to setup a simple 2 160GB HDD RAID 0 setup to use for installation of Windows 7 Ultimate, however I am coming across some issues regarding setting it up. I am able to change my SATA mode to 'Raid from AHCI' then create an array for my two hard drives, however when I install the operating system on the Raid HDD, I am unable to boot into windows, every time the BIOS Posts and then hands over to the OS after the installation it begins to update the registry and then restarts and continues the cycle.

I am using -

Asrock 970 Extreme3 Motherboard AMD Phenom x4 II 965 BE 160GB WDC WD1600AAJS-07PSA0 ATA Device (For the Raid setup, identical drives)

I am currently running windows 7 ultimate off my 3rd HDD and have create a software strioed RAID 0 using disk management which seems to work, however I want to be able to install windows onto the raid drive and not my standard HDD.

I am currently running my 250GB HDD in AHCI mode, if I run RAID mode, the 250GB fails to boot, giving my a disk fail error, I was under the influence that standard Sata drives could still load whilst in RAID?

Thanks! Anymore information you need, I can answer swiftly.

ADDITIONAL INFORMATION AND IMAGES TO EXPLAIN.

I have attempted another setup following these steps in order to get this to work.

1 - I changed my controller in the BIOS from AHCI to RAID and rebooted.

http://imageshack.us/photo/my-images/819/sam3743.jpg

http://imageshack.us/photo/my-images/545/sam3744.jpg

http://imageshack.us/photo/my-images/209/sam3742r.jpg

2 - I booted into the RAID controller and create a RAID 0 array seen in image 1

http://imageshack.us/photo/my-images/806/sam3746.jpg

http://imageshack.us/photo/my-images/689/sam3747.jpg

http://imageshack.us/photo/my-images/9/sam3745i.jpg

3 - I booted through my Windows 7 Ultimate disc when the array was setup

4 - Loaded the drivers needed for windows to see my new 'Raid Volume'

5 - Began the installation allowing a new partition to be created & a system reserved partition to be created.

5a - I have done the following step without creating the two partitions and I still get the same results

6 - Windows finished the installation and rebooted to system

7 - Windows began to load and update registry settings, Image below again.

http://imageshack.us/photo/my-images/571/sam3740f.jpg

8 - Windows rebooted and crashed

http://imageshack.us/photo/my-images/502/sam3741.jpg

9 - Attempted to repair the new installation using a Windows 7 repair disc, loaded the driver and selected the boot drive, however nothing could be repaired

10 - System reboots again, nothing will boot into windows. Using my 250GB i get a disc failure on bootup due to being in RAID mode

11 - Changed the controller back to AHCI and booted through the 250GB to get the system to work

12 - The RAID HDD shows up, however to use it, I need to format the drive completely

Like this post
retep888™

Likes # 0

You seem to have done the correct procedures, I don't know what went wrong there. Are those 2 160GB HDD new ?(I can see they're identical.) Have you tried installing Windows on the RAID 0 array after disconnecting the single 250GB HDD first?

I have a similar setup on one of the power PCs but RAID 0 on 2 SSDs & a single 300GB WD VelociRaptor on its own, it works perfectly alright & am able to choose which drive to boot from using the boot menu, now preparing for putting in extra 4 SSDs for a separate RAID 5 setup & get rid of the WD VelociRaptor(too slow), should be fun.

Like this post
DaleF

Likes # 0

They're not brand new, however they work fine like any other hard drive, I have attempted this procedure with just the 2 160GB HDD's and I still get the same problem.

I also tried another Windows 7 disc which was 32 bit professional, loaded the different drivers and still the same problem.

I was thinking that my motherboard might need a BIOS update/flash? Would that in anyway help, as I did notice there are some available, however I normally never would flash my Mobo without an actual reason.

And 6 SSD's? That should be one speedy pc build!

Like this post
retep888™

Likes # 0

I doubt updating the Bios will solve your problem as all the versions say nothing about RAID issues.

To be honest if your main purpose of RAIDing 2 mechanical Sata II drives is to improve performance then you'll be disappointed plus RAID will put a lot of stress on these drives if they're not the RE or Black Caviar version ,they'll fail prematurely. I hope you know the consequence of RAID 0 failure, a modern Sata III drive will outperform 2 Sata II drives in RAID.

The extra 4 SSDs was a long story & were replacements from the manufacturer, I had them for over 3 years & had a lot of problems, been going back to them & got replaced with refurbished drives for numerous times. Eventually I got 2 SSDs from a different manufacturer (while I'm waiting for the replacements) & set up in RAID 0, nothing has gone wrong since.

This time the SSD manufacturer sent me 4 brand new different model (the original ones were discontinued long time ago) as a gesture of goodwill , I've got to test them,right? :)

Like this post
DaleF

Likes # 0

Hmm, I guess the benefits aren't too great which I had already realised, however was more inclined to doing it, for the knowledge of doing it I suppose, and being as I've correctly set it up several times and it failed, I wanted to know why!

I'm unsure whether it's the drive's, drivers, motherboard or the OS, but it seems to be working fine for everyone else.

And to quickly clarify, If I run Raid mode, should AHCI HDD's still be able to boot if they have windows installed, or should it fail?

Like this post
retep888™

Likes # 0

And to quickly clarify, If I run Raid mode, should AHCI HDD's still be able to boot if they have windows installed, or should it fail?

Yes, it should be bootable under RAID mode, normally non-RAID disk will appear as single disk or non-member disk in RAID array bios setup.

I've been using Intel RAID controller all the time (have steered away from AMD/Nvidia chipset, very problematic years ago for me) therefore can't give you a first hand diagnosis.

If you really want to do it then one alternative is getting an economical pci-express RAID card click here or pci RAID card click here for a change.

Like this post
DaleF

Likes # 0

Well I contacted Asrock directly through email and they told me to flash my Bios and try it from there. I did and it worked, however the system kept restarting when installing drivers which was weird, so instead I'm going to use them as a software raid for documents/programs/games & what not instead of the C drive. See how it runs from there on and figure out whether the HDD's are the problem or if it's the motherboard, as I'm unsure.

But, from what I've been told, flashing the bios and repeating the stages works and did work for me, until it started playing up, however it did get the system installed and working, so this seems to be the way to fix it, just it might be my own HDD failing or not running as they should.

Original BIOS: Version 1.05 Flashed BIOS: Version 1.6

I used instant flash, downloaded directly from there website, the links are below. Seems to solve my issue, however AHCI still wouldn't boot whilst in Raid mode, again, confused.

Bios flashing version 1.6

http://www.asrock.com/mb/AMD/970%20Extreme3/?cat=Download&o=BIOS

Raid Drivers Needed

http://www.asrock.com/mb/AMD/970%20Extreme3/?cat=Download&o=Win764

Thanks for the help & support Retep888, shame we couldn't sort the issue eventually, I'll retry Raid in the future with some more reliable & new hardware.

Like this post  

Reply to this topic

This thread has been locked.



IDG UK Sites

Where to buy iPhone 6 and iPhone 6 Plus in the UK: Launch day price, deals and contracts

IDG UK Sites

Is Apple losing confidence in itself?

IDG UK Sites

Professional photo and video techniques for perfect colours

IDG UK Sites

How (and where) to buy an iPhone 6 or iPhone 6 Plus in the UK. Plus: What to do if you pre-ordered...