We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

USB message Win 7 64bit


highside

Likes # 0

Why do I get regular messages from Windows telling me that a device would work better if I connected it to a USB2 port when my PC has only USB 2 and the powered hub I use is also USB2?

Thanks for looking.

Like this post
difarn

Likes # 0

You may find this article useful.

Like this post
Fruit Bat /\0/\

Likes # 0

You may have a problem with the enhanced driver in device manager.

Look under USB and check one of the drivers shows as Enhanced Driver.

Like this post
highside

Likes # 0

Under USB Serial Bus controllers I have Generic USB Hub Intel(R) ICH(Family USB Host Controller - 2934 to 2939 (ie six entries) Intel(R) ICH9(Family USB Enhanced Host Controller- 293A Intel(R) ICH9(Family USB Enhanced Host Controller- 293C USB Composite Device USB Mass Storage Device USB Root Hub USB Root Hub USB Root Hub USB Root Hub USB Root Hub USB Root Hub USB Root Hub USB Root Hub All show as 'working properly'

Like this post
Fruit Bat /\0/\

Likes # 0

They look OK

Is it one particular device causing the message or one particular Port?

It could be worth uninstalling ALL the USB drivers and rebooting and let windows reinstall the USB drivers. However this can be a prolem if you only have a keyboard works by USB either wired or wireless.

Like this post
difarn

Likes # 0

If you are satisfied that your usb ports are working correctly and the message is just niggling you the article I posted earlier tells you how to disable this....

To do so, open the Device Manager (type Device Manager into the Start menu and press Enter), right-click the USB host controller under Universal Serial Bus controllers, and select Properties. Uncheck the Tell me if my device can perform faster check box on the Advanced tab.

Like this post
highside

Likes # 0

Thank you both. Still looking at that interesting article. Probably disable as you suggest doesnt seem too important. Suddenly realised it seems to be to do with the USB mouse so will try changing that first.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

Apple's 2014 highlights: the most significant Apple news of 2014

IDG UK Sites

2015 creative trends: 20 leading designers & artists reveal the biggest influences & changes coming)......

IDG UK Sites

Ultimate iOS 8 Tips: 35 awesome and advanced tips for using iOS 8 on iPhone and iPad