We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

USB drive not recognising memory stick


osben

Likes # 0

Hi When I put the memory stick into any of the USB drive on the computer I get a message come up firstly asking me to format the memory stick. If I click on the drive designation I get the following message:

{{ K:drive is not accesible. The volume does nt contain a recognised file system. Make sure that all required file system drives are loaded and that the volume is not corrupted.}}

I know that the memory sticks are OK as I have tried several and also tried all the USB slots on the computer.

I cannot remeber having done anything to have caused the problem since last using the USP drives.

Also when I put a CD into either of the drives which I know have got an automatic run programme on them, Nothing happens. I have to bring up the CD file contents and start the Cd manually. I can hear the drive running though.

Does anyone know what is wrong with both problems and how to rectify please.

Regards

Like this post
buteman

Likes # 0

You could check in device manager. Click on universal serial bus controllers and see if any yellow exclamation marks on there.

Like this post
Fruit Bat /\0/\

Likes # 0

CD

Autoplay Repair Wizard http://www.microsoft.com/downloads/details.aspx?FamilyID=c680a7b6-e8fa-45c4-a171-1b389cfacdad&DisplayLang=en

Autoplay disable/enable 1. Click Start, click Run, type regedit in the Open box, and then press ENTER. 2. Locate and click the following registry key: HKEYLOCALMACHINE\System\CurrentControlSet\Services\CDRom 3. To disable automatically running CD-ROMs, change the Autorun value to 0 (zero). To enable automatically running CD-ROMs, change the Autorun value to 1. 4. Restart your computer.

If Autoplay does not work in XP (may also work for vista and 7), here's a fix:

Run Regedit Go to HKEYCURRENTUSER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\Explorer. Delete the Key "NoDriveTypeAutoRun" Reboot the Computer.

Like this post
osben

Likes # 0

Hi Guys

Thanks for getting back to me.

buteman - No apparent problems in the Devise Manager.

Fruit Bat /\0/\ - tried to use the Autoplay Repair Wizard but it tells me that it will not work for 64bit systems.

Also went into the system registry and there were two entries under CDROM - Enum and Parameters. Neither had any mention of disable / enable.

Do you know what the problem is with the USB drives??

Regards

Like this post
Fruit Bat /\0/\

Likes # 0

  1. Click Start, click Run, type regedit in the Open box, and then press ENTER.

  2. Locate and click the following registry key: HKEYLOCALMACHINE\System\CurrentControlSet\Services\CDRom

  3. To enable automatically running CD-ROMs, change the Autorun value to 1.

  4. Restart your computer.

Like this post
Fruit Bat /\0/\

Likes # 0

Run Regedit Go to HKEYCURRENTUSER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\Explorer.

set the value for the Key "NoDriveTypeAutoRun" to 91

Reboot the Computer.

Like this post
Fruit Bat /\0/\

Likes # 0

Please confirm USB stick works OK on another computer?

No USB sticks work on this computer?

Do any USB devices work on this computer?

Like this post
osben

Likes # 0

Hi Fruit Bat /\0/\

USB sticks work on another computer.

No USB sticks work on this computer.

Even when I conect my TomTom sat nav via USB I get the same problem.

I can swap printers and scanners around from one USB to the other and they still work as does my back up mouse and my wireless mouse/keyboard which is connected via USB

The version of Windows 7 is 64bit and all was well the last time I used the flash drives to store files.

any help appreciated.

Like this post
Fruit Bat /\0/\

Likes # 0

Now that's an odd one

if sticks are OK and other devices work on your machine, but not sticks.

I can only assume that widows has lost / corrupt the drivers for sticks and doesn't recognise them a repair of windows may be needed won't hurt anyway:0)

SFC/ SCANNOW

  1. Open a elevated command prompt. (Open the Start Menu. Click on All Programs and Accessories, then right click on Command Prompt and click on Run as administrator.)

  2. In the elevated command prompt, type sfc /scannow and press Enter. NOTE: This may take a little bit to finish.

  3. When the scan is 100% complete close the elevated command prompt.

    NOTE When SFC runs, it logs it's actions to the C:\WINDOWS\LOGS\CBS\CBS.LOG. This will show you how to see only the specific SFC entries with the [SR] tags in the CBS.log. This can be helpful to show you what files SFC could not fix automatically if you wanted to try and manually replace them. Open a elevated command prompt. In the elevated command prompt, type the command

findstr /c:"[SR]" %windir%\logs\cbs\cbs.log >%userprofile%\Desktop\sfcdetails.txt

and press Enter. This will place a sfcdetails.txt file on your desktop with the SFC scan details from the CBS.LOG.

Close the elevated command prompt.

Open the sfcdetails.txt file on your desktop to see the SFC scan details in the CBS.LOG.

You can safely delete the sfcdetails.txt file afterwards if you like.

Like this post
osben

Likes # 0

Hi Fruit Bat /\0/\

Thanks for that but before I try it, last night I did in fact format a memory stick as it asked and was successful using NTFS file format ( it wouldn't let me use Fat32 file format). I can now read/write from the stick as normal.

Given the above, would it be safe to assume that the other memory sticks are formatted with Fat32 file format and that is why my computer will not recocnise them. If so:

A) why will the computer not recocnise the sticks now when it used to.

B) is there any way that I can set the computer to acknowledge Fat32 file system as well as NTFS so that I can at least download all the info I have on the memory sticks and then re-format them in NTFS file format to solve the problem.

Any help would be apreciated

Regards

Like this post
Fruit Bat /\0/\

Likes # 0

Try converting the sticks to NTFS you should be able to do this without losing the data on the sticks

To convert your drives to NTFS: Right click on 'my computer' and select 'manage'

From the computer management window, expand storage and select 'disk management.'

Using the 'file system' column of the upper pane of this window, you can easily check what file system each of your logical drives is using. Make a note of this information.

Now open a command prompt window by going to 'start\run' and typing 'cmd'

To convert a disk to NTFS, type 'convert (drive letter): /fs:ntfs'

So for example, if you were going to convert your E: drive usb stick, you would type

Convert e: /fs:ntfs

at the prompt.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

6 cheapest 4K TVs in the UK 2014: Get a UHD telly without breaking the bank

IDG UK Sites

Apple MacBook Air (11-inch, 256GB, Early 2014) lab tests and benchmarks

IDG UK Sites

How to stop your parents opening and responding to phishing emails

IDG UK Sites

Google to ship first Project Ara developer boards in July