We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
 
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

computer Graphics not displaying properly


nikef

Likes # 0

Hello all . I have a problem with my computer graphics its not displaying properly ..looks like lots of small squares .running windows 7 ..display Radeon X1300 / X1550 Series (Microsoft Corporation - WDDM) [Display adapter] Radeon X1300 / X1550 Series Secondary (Microsoft Corporation - WDDM) [Display adapter] HP w1907 [Monitor] (19.1"vis, s/n CNN7381187, September 2007)..most effects on-line games .. I have a picture but not sure how to post it here ..any help would be appreciated thanks.

Like this post
KRONOS the First

Likes # 0

you can post your image here Photobucket When you have uploaded your image hove your mouse over it then click on the direct link box and post the link here.

But you could try downloading and installing the driver for your graphics Click here.

Like this post
nikef

Likes # 0

Thank you ..the driver link is for xp ..is there one for windows 7 ..i will try and upload the picture now .

Like this post
nikef

Likes # 0

Like this post
KRONOS the First

Likes # 0

Try this one Click here

Like this post
KRONOS the First

Likes # 0

Yep that worked.

Make sure that the cable has not come loose and if you do not mind opening your PC up then you might like to remove the graphics card, make sure that any fan is clear of dust then replace it making sure it is seated correctly, then reattach the cable and boot your PC. Do this before you try the driver.

Like this post
nikef

Likes # 0

Just a little more info ..when looking at photos on fb or Photobucket they are all clear ..it happens on fb games and on the computer itself but not my pictures stored on the pc .. I really appreciate any help thanks

Like this post
nikef

Likes # 0

Sorry chronus ..crossed posts will do that now ..thank you

Like this post
nikef

Likes # 0

Hmmm not sure what that second link you gave me ..but its a bad site ..messed up my computer ..turned off my antivirus and firewall and in - stalled babylon search browser ..i am struggling to get rid of it now :(

Like this post
KRONOS the First

Likes # 0

I use the Guru all the time, I certainly would not send to to a bad site.As for installing the Babylon search it would have asked you if you wanted to install it which you must have missed. But you can remove it easily enough in add and remove or rather Programs and Features as its called in Windows 7.

Like this post
nikef

Likes # 0

click the link and see if you get the same ..i have tried add and remove ,it removed the stuff but its still on my browsers

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Amazon 3D smartphone release date, price and spec: The hologram phone?

IDG UK Sites

You're never alone with a clone: How the App Store got taken over by copycats

IDG UK Sites

PCs vs consoles: PCs still pwn when it comes to gaming (and everything else)

IDG UK Sites

The art of rebranding: Creative agency The Neighbourhood explains how & why it rebranded