We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

PC won't connect to internet


JHHT

Likes # 0

I recently bought an Advent PC running Windows7 and connected it to a home network with other devices that have a mix of wireless and cable connections. All work fine with the exception of the new PC which is fine some days but on others it needs to be rebooted several times before it will connect to the internet. Today after numerous reboots including the router it stil won't connect.

I have rebooted the router and replaced the ethernet cable. Windows diagnostics can,t find any faults.

Any advice please?

Like this post
onthelimit1

Likes # 0

If others are OK, and the new one has problems connecting, it's either a driver problem, or the network card/chip has an intermittent fault, I'd say.

You could try downloading and installing the latest driver - look at Network in Device Manager to find out the manufacturer and model. If that doesn't work, I'd be tempted to assume it faulty and ask for an exchange.

Others may have other ideas, of course, so best wait for more responses.

Like this post
spuds

Likes # 0

Considering that some devices appear to be working and others do not, then it could be a number of things. What I would suggest is that you go to your ISP's website and see if they have an instruction setting-up page, and see if that suggest anything, possibly a few tick and apply boxes?.

My own ISP is very good at this, both on-line and via telephone support, but tend to fail on other things ;o)

Like this post
JHHT

Likes # 0

A quick update. I had a look for a new driver but the only one I could find was older than the PC so I didn't bother. I also contacted my ISP who considers that the problem is computer issue rather than anything to do with them.

I have found that if I disable the connection and then re-enable I can get a connection straight away. It's not an ideal solution but it is a big improvement. I have informed my ISP about this and perhaps I will get a further reply from them.

Like this post
Fruit Bat /\0/\

Likes # 0

I have found that if I disable the connection and then re-enable I can get a connection straight away.

Check in device manager your network adaptor card - right click - select properties - power tab - ensure allow the computer to switch off ... is unticked.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

LG G Watch review: Android Wear smartwatch is the best around, so far

IDG UK Sites

How to join Apple's OS X Beta Seed Program: Get OS X Yosemite on your Mac before public release

IDG UK Sites

Why the BBC iPlayer outage was caused by a DDoS attack: Topsy and Tim isn't *that* popular

IDG UK Sites

See Glasgow 2014 in UHD as history is made