We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Windows 7 Sleep Function


bpzoom

Likes # 0

Lately the Del Desktop PC with Windows 7 64 bit refuses to come out of sleep when it has been left for a period of hours. When I manually send it to sleep it does so and the mouse and keyboard are set to revive it. It revives as it should do if I move the mouse or hit a key. However whenever I leave it asleep for a long period such as several hours, it refuses to awake and I have to force a reboot with the power button. That produces the black screen which you get after a crash. Any ideas what might cause it to revive after a short period of sleep but not after a long period? I have changed nothing except that I have applied Windows updates.

Like this post
Peter

Likes # 0

bpzoom,

Are you leaving the laptop power unit plugged into the laptop and switched on at the mains socket or just running the laptop from its battery when in sleep mode?

It could be that the battery is running down when in sleep mode.

Peter.

Like this post
bpzoom

Likes # 0

Peter, It is a desktop PC.

Like this post
rdave13

Likes # 0

Go to device manager and double click universal serial bus controller and in the usb root hub list, right click each one, select properties, click on the power management tab and untick Allow the computer to turn off this device to save power. See if that helps.

Like this post
Peter

Likes # 0

bpzoom,

Sorry, misread your posting.

Peter.

Like this post
bpzoom

Likes # 0


rdave3 said Go to device manager and double click universal serial bus controller and in the usb root hub list, right click each one, select properties, click on the power management tab and untick Allow the computer to turn off this device to save power. See if that helps.

Read more: http://www.pcadvisor.co.uk/forums/1/helproom/4142092/windows-7-sleep-function/#ixzz1xkvvlChx

Thank you. I have tried that and it seems to have worked so far. Short spells and one 2+ hour spell all came out of sleep. Touching wood but many thanks for your advice.

Like this post
bpzoom

Likes # 0

I regret to say that the problem has returned after 2 days of working OK. I guess I will have to live with it, until maybe Microsoft resolve it, assuming that is possible, given all the different configurations existing in the world.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

iPad Air 2 release date, price, specs, new features: world's thinnest tablet also gets Touch ID

IDG UK Sites

Why you shouldn't buy the iPad mini 3: No wonder Apple gave it 10 seconds of stage time

IDG UK Sites

Will Photoshop work with Yosemite? And will Illustrator, After Effects, Premiere Pro or the other A?......

IDG UK Sites

Should I upgrade from Mavericks to OS X 10.10 Yosemite? What you need to know before updating to...