We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Windows 7 Won't Stay Asleep


Scrivers

Likes # 0

I've started having problems with the sleep mode. I'm on Windows 7 and some times, when I set it to sleep it's fine. Other times it comes out of sleep mode for no apparent reason. It's not a mouse problem & I don't think it's a router/Internet problem waking it up, because it's only started doing this over the last few months. Anyone help?

Like this post
Zeppelyn

Likes # 0

Using the command prompt try these for starters:-

powercfg -lastwake

should tell you what last woke the pc.

powercfg -waketimers

lists all devices able to wake the pc.

It could also be a program or scheduled task thats doing it. Have you install anything lately that runs on a schedule?

Like this post
Scrivers

Likes # 0

Hi Zeppelyn, thanks for your response. Powercfg -lastwake gave me the following; Type: Device Instance path: USB\Root\Hub20\4&2f74619d&0 Friendly Name: USB Root Hub Manufacturer: Standard USB Host Controller This must be my USB powered hub. Strange thing is though it didn't do this previous. I'll try switching it off when I put the pc to sleep and see if that works.

Powercfg -waketimers indicated that I have no scheduled timers

Thanks for your help.

Like this post
rdave13

Likes # 0

You could go to device manager, find the root hub,right click, select properties,power management and untick the box to allow this device to wake the computer. Make sure you select the right one as you'll need a usb keyboard to wake the PC.

Like this post
T0SH

Likes # 0

Have you checked in the BIOS settings for an enabled settings with wording like "Wake on Lan" ?

Cheers HC

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best camera phone of 2015: iPhone 6 Plus vs LG G4 vs Galaxy S6 vs One M9 vs Nexus 6

IDG UK Sites

In defence of BlackBerrys

IDG UK Sites

Why we should reserve judgement on Apple ditching Helvetica in OS X/iOS for the Apple Watch's San...

IDG UK Sites

Retina 3.3GHz iMac 27in preview: Apple cuts £400 of price of Retina iMac with new model