We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Can connect to router, but no internet


slowhand_1000

Likes # 0

Hi

I've recently did a factory reset on an old Sony Vaio running Vista Home Premium.

Everything works fine except for trying to get onto the internet via wireless. It connects to the router (BT Business 2Wire 2701) but can't get onto the internet. It can get onto the internet using ethernet and also if the router has WEP or no encryption. But I can't get it to connect using WPA and or WPA2.

Other users on XP and Windows 7 can get onto the internet via wireless ok using WPA.

Regards

slowhand

Like this post
slowhand_1000

Likes # 0

PS

Forgot to mention I have been onto Sony site and updated all drivers

Like this post
difarn

Likes # 0

You said you have updated all drivers - is this for the wireless card also?

You could try flushing the DNS cache

Click the Microsoft Vista Start logo in the bottom left corner of the screen Click All Programs Click Accessories RIGHT-click on Command Prompt Select Run As Administrator (if necessary_ In the command window (black box) type the following and then hit enter: ipconfig /flushdns (there is a space between the g and /) You will see the following confirmation:

Windows IP Configuration Successfully flushed the DNS Resolver Cache.

Does the vista pc have the latest Service Pack installed?

Have you tried:-

Putting the laptop near to the router when trying to connect.

Go to 'Manage wireless networks that use (Wireless Network Connection)' box and remove your existing SSID network. Then click the add button and REDO your SSID information. Make sure you use 'WPA- Personal' and NOT 'WPA2-Personal' when choosing your security type.

If this doesn't work this article may help that talks you through a registry fix.

Like this post
T0SH

Likes # 0

Nine times out of ten this problem occurs when the wireless network connection type gets set by default to "Public" and provides a local only without internet connection, you can however change this to "Private" or "Home" by right mouse clicking the icon in network properties to get a local and internet connection , if all else fails totally removing the troubled wireless connection from the list and remaking it should get you to an option screen where you can choose home from the three options

Cheers HC

Like this post
Ashrich

Likes # 0

Make sure you have the Vista service packs installed ( all of them ) for WPA to work correctly .

Ashley
Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

45 Best Android games: top Android games for your smartphone or tablet in 2014 (24 are free!)

IDG UK Sites

How Apple, Adobe, Microsoft and others have let us down over UltraHD and hiDPI screens

IDG UK Sites

Do you have the X-Factor too? Mix Off app puts fans in the frame

IDG UK Sites

iPad Pro release date, rumours and leaked images - 12.9 screen 'coming in 2015'