We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Epson SX445W wireless connection


Borrel

Likes # 0

Hi

New to this site; I wondered if anyone had the same problems with wireless connection, and could recommend a printer that might avoid the problems.

As background, i have just bought a SX445W all in one and tried to set it up for wireless connection, but it would not be recognised. Eventually managed to get a connection using the manual set up (and after wasting several hours trying different methods, and talking to Epson). Tried it again a few days later, and no joy, all the settings are correct, but no test sheet can be printed. Looked though as much of the Epson support material as I could handle, have to say they tend to write with assumed knowledge and rather ambiguously; makes for slow and painful reading. Eventually took time off work and contacted them again today. They agreed that all should be working okay, and wondered if I had made any changes to my laptop. I hadn't, and no auto updates have been made. I was sent a bundle of "support sheets", some of which I had read already, others that did not address the problem. Nothing seemed to work, and they then decided that the problems must be in my network setting or with my router, and basically declined to assist further. My network is working fine, and so was the printer, now it is not; it leads me to think that the problem still lies with the printer connection. Anyway, it seems I now have to choose between sending it back, and being without a printer, or not using the machine wirelessly.

From reading other feedback on Amazon, etc, this appears to be a regular problem; so why can Epson get away with it? Were this to be a washing machine or a camera, and such a lot of user input was required, and even then the product might, or might not work, it would be considered unfit for purpose. I understand from their support staff that all Epson printers work on the same wireless system, and I have to conclude that this is a Beta product, or at least, a beta facility.

So, can anyone recommend a workable wi-fi printer; preferably one that will work with water fast inks. Or is it a question of waiting until the technology improves?

Like this post
Zuminuk

Likes # 0

I purchased a EPSON STYLUS SX445W yesterday and experienced the same/similar issue; wireless connectivity just not playing ball (connecting but not connected).

After a bit of fiddling I isolated the issue to a wireless security mismatch between the printer and my router (NETGEAR WNR2000).

Rather than the SX445W automatically syncing with the routers security configuration (automatically, not manual option available) it was connecting with a mismatch

Resolved issue by changing routers wireless security setting to match that the printer was trying to us (WPA-AES)

OK not 100% ideal, but can now print on what otherwise seems to be a wonderful wee printer :-)

Zuminuk

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Black Friday 2014 tech deals UK: Get bargains on phones, tablets, laptops and more this Black...

IDG UK Sites

Tomorrow's World today (or next year)

IDG UK Sites

25 iOS apps turn (Red) for World AIDS Day campaign

IDG UK Sites

Advanced tips for Mac OS X Yosemite: use Yosemite like an expert - 5 new tips added