We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Maxtor hdd - unknown device and doesnt ask for drivers?


theDarkness
Resolved

Likes # 0

My external hard drive was working 100% up until today, and for no good reason upon connecting today to any usb port, it tells me it is an unknown device. The drive still whirrs when I connect the cable. What should I do? Windows simply says to try reconnecting it, or replace it. Reconnecting just gives me the same message. 500GB of data gone, and I was all set to get a second hdd as a secondary backup soon too :( any ideas on how to fix? thanks

Like this post
Nontek

Likes # 0

You could try connecting it before starting PC.

Like this post
theDarkness

Likes # 0

thanks ill try a restart

Like this post
Nontek

Likes # 0

You could try connecting it before starting PC.

Like this post
Nontek

Likes # 0

Ooops - sorry about duplicate!

Like this post
theDarkness

Likes # 0

interestingly, it didnt help - the system told me it was 'reinstalling drivers for unknown device'.. and that it was successful.. but still, nothing shows up in my computer :(

Like this post
Fruit Bat /\0/\

Likes # 0

OK sounds like the PC is not liking the USB to SATA? / IDE? interface.

This doesn't mean your data is gone, you could remove the drive from the case and connect directly to the PC motherboard if you have spare power and data cables.

First try:

Device manager - View - tick show hidden devices - click each hidden device (greyed out) and uninstall also unistall any devices showing with red exclamation or question mark.

Run a registry cleaner like the one in CCleaner

reboot the machine with the drive connected windows will find and attemot to install new hardware.

Hopefully your drive will now install again correctly.

Like this post
theDarkness

Likes # 0

thanks for the replies and tip about directly connecting to a pc motherboard as a last resort,its this one, built in fan, sata I think, and getting on a bit. Unfortunately the way these drives are built, i dont think removing the case would be a very easy job. Nothing seemed to show in device manager, although I may have just missed it. I likely bought it just after 2008. It hasnt been used on a constant basis, and its health has always shown as being very good. I know thats no excuse for not having that secondary backup, since drives can fail any time.

After trying a recommended sfc /scannow check from some random website, I managed to solve the problem (temporarily at least to be able to read it): I simply changed the USB cable. Which seems very odd for a temporary solution, as the one used beforehand worked perfectly yesterday, and I never change these cables on a regular basis. I was certain that the previous one was the original. Im now going to backup as much as I can onto another hd right now, but have you ever heard of an identical cable type having issues with an external drive? Im not having any issues browsing through and opening any of its content, so do you think it could still be the first signs of an aging drive? I always hear about the average hard drive lifespan being completely unpredictable and lasting anywhere between 2-6 years. Perhaps thats one reason as to why hdds are so cheap, lol, but the technology regarding lifespan has surely got to improve and become far more reliable when you consider the size hds are getting.

Do you think I should simply retire this external hdd, or simply do a secondary backup on a constant basis, continuing to use it?

thanks

Like this post
Fruit Bat /\0/\

Likes # 0

I still use HDDs that are 15yrs old.

There is probably nothing wrong with the drive, it is often the USB interface that fails with external drives.

Sometimes its conflicting drivers that cause a problem and the drive works OK when plugged into a different machine hence my advice about device manager earlier.

Like this post
theDarkness

Likes # 0

Do you have secondary backups of everything important, or do you not put that content onto any of your older hds? Ive noticed with the usb cable that didnt work, there is a large '' symbol near the end, I assumed this was simply relating to maxtor, but now Im not so sure. On a slightly different more confusing note ive also noticed that there are type a and type b usb cables, so now im wondering if I had put the right cable in after all, since I do have other devices that use the same usb leads. Ill need to work out what other devices use the same type of cable and try the questionable cable with something else, to see if that really was the problem. If the cable works with any other device or hd, and the unconnecting hd continues to now work, and I cant find out about conflicting drivers through windows error logs or similar, then perhaps Ill never know what the issue was, but for now the panic is over, lol. No other systems to try the same hd on here at the moment.

Like this post
theDarkness

Likes # 0

ps that should have been 'large M symbol'

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Motorola Moto G2 release date, price and specs: Best budget smartphone gets upgrades

IDG UK Sites

How to join Apple's OS X Beta Seed Program: Get OS X Yosemite on your Mac before public release

IDG UK Sites

Why the BBC iPlayer outage was caused by a DDoS attack: Topsy and Tim isn't *that* popular

IDG UK Sites

How to make an 'Apple iWatch' using an iPod nano and a 3D printer