We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

PC Won't Start


Mygeneration

Likes # 0

I've got an old Bravo Sempron PC which I was hoping to use for backup as I now have a Delta V3, I think it's called.

Old PC was working but I think the hard disk may have been on the way out.

All that happens now is that the fan attached to the motherboard comes on. That's it. The fan at the back of the casing doesn't work, there's no sign of the hard drive booting up, and I can't even switch off using the on/off button, I have to unplug.

I even tried to open the CD drive which seems to have its own power supply but nothing.

No chance of getting as far as the bios!

Any ideas?

Like this post
Fruit Bat /\0/\

Likes # 0

Disconnect anything plugged into USB ports

open case and Disconnect HDD and DVD drives

See if it will boot to an error message or to BIOS.

Like this post
Mygeneration

Likes # 0

Thanks, tried that. I also replaced the cmos battery but no change.

It has a winfast 760GXK8MC motherboard.

I'm wondering if it's the power supply unit bacause whilst the fan on the motherboard works, the DVD drive won't open.

Like this post
KRONOS the First

Likes # 0

Is this your Mobo? Foxconn winfast 760GXK8MC

To be honest it could be any manner of problems, from a faulty PSU to ram to motherboard. So it depends on how much you want to get this old,you don't say how old, PC working. You could certainly try another PSU if you have one or can get one cheaply enough, that would at least rule power supply as the cause or not.

Like this post
Mygeneration

Likes # 0

Thanks. The PC is 5 years old.

I have just tried a new PSU, exactly the same problem. Only the fan on the motherboard works. I don't even think the new PSU fan was working.

Now I'm wondering if this is caused by a hard disk failure, but wouldn't I still be able to get into the BIOS?

Thanks

Like this post
KRONOS the First

Likes # 0

Sounds like mobo problems then.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Galaxy S6 release date and specs rumours: When will the Galaxy S6 come out?

IDG UK Sites

How to win iTunes Festival 2014 tickets: See Pharrell Williams, Sam Smith, Kylie & more live, for...

IDG UK Sites

Microsoft's all or nothing bet on Windows Phone is the best way forward

IDG UK Sites

Google adds better type rendering to its Chrome browser on Windows