We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

USB 3.0 drivers, where can I get them from?


Migwell

Likes # 0

Trying to install a USB 3.0 Card in my computer but it aint working where can I get the drivers from. The little disk that came with the card will seem to function, I was told to look for VL800 Driver VL41A_WHQL|V1.4A_WHQL|Setup.exe, but I can't find it anywere on the disk. Help Please

Like this post
Ian in Northampton

Likes # 0

This guy

http://forums.extremeoverclocking.com/showthread.php?p=4008785

seems to have had the same problem...

Like this post
rdave13

Likes # 0

Try this, insert the CD driver disc in the drive. Click start- run- and type VL800 DRIVER V1.41AWHQL\V1.41AWHQL\Setup.exe or copy and paste to the run box. Follow on screen instructions.

Like this post
Ian in Northampton

Likes # 0

I guess the question is: can you find anything on the disk with 'VL800' and 'setup.exe' in its name? That would probably be what you want. In the discussion I referred to earlier, it looks like some of the characters in the file name had got reproduced in Chinese.

Like this post
Ian in Northampton

Likes # 0

Or you could try the generic driver here:

http://www.via-labs.com/en/support/downloads.jsp#hostdriver

Like this post
buteman

Likes # 0

Just a general question.

After installing the USB3 drivers do you then need a USB3 Mouse and is there such a thing.

Or do you just use the normal USB2 mouse in the USB3 port.

Will have a look on my other computer to see if it has a USB3 Driver on it.

Like this post
Migwell

Likes # 0

When I tried to look into the disk all I could do was see the directories, and no further as the disk will not respond after that. Also I wondered if the power connection on the card will be needed as I have seen that it is some times required.

Like this post
KRONOS the First

Likes # 0

As to your question about whether the USB 3 card need a power connection,unlikely, but it would be useful to know make/model of card.

Like this post
Migwell

Likes # 0

I don't know about the make, how can I tell what it is?

Like this post
buteman

Likes # 0

You would have to take it out again I suppose or copy and paste the data from the website you bought it from.

Something like this.http://www.via-labs.com/en/products/vl800/index.jsp Now thats probably not the one that you have If you bought it from the internet you must have seen what you were buying.

I would imagine there must be a sticker or something on it that will tell you what make and model it is.Not sure if SIW will show it or not.Did Microsoft not update a driver for it when you rebooted.

Does nothing show for it under universal serial bus controllers in device manager.

Like this post
Migwell

Likes # 0

In control panel / device manager, it showes up as universal serial bus controllers then as Via USB 3 Root hub. After trying to update the driver from properties, it then has told me that the best driver is installed and up to date. But still not working, also no Yellow marks against it. Thanks for trying to help. Migwell

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

Apple's 2014 highlights: the most significant Apple news of 2014

IDG UK Sites

Watch this heartwarming Christmas short by Trunk for composer John Rutter

IDG UK Sites

Ultimate iOS 8 Tips: 35 awesome and advanced tips for using iOS 8 on iPhone and iPad