We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Win XP PC Won't Boot


Inside Edge

Likes # 0

Hi, .....can anyone offer advice with this one ....

My Mesh PC running Win XP SP2 wont boot up at all. It powers on, the fans all run and the DDD is spinning but there is nothing on the screen at all. There are no beep at all either. The power light on the case is on, and the orange HDD light is on and steady. The light on one of the DVD drives is on and staedy but I can't open either drawer, so I can't put a recovery disk in. The screen gives a message that it can't see a signal, so that seems to be ok.

The only clue I have is this: When I installed SP2 several years ago, it was a nightmare but with help from this forum and Mesh, I got it running. I never went near SP3. Since then, the PC has always been a bit picky about what Win updates it'll install and which it won't. For a couple of yeras, I've always shut it down by choosing "shutdown without installing updates". Last night, my daughter shut it down in the more normal way and it began installing 26 updates ! Not wishing to crash it, I let it do it's thing and went to bed while it worked away. It shut down but today it won't boot up. This could be a red herring of course, but .....

There is no info reaching the screen at all, so no opportunity to diagnose of hit F8 or whatever. Nor to put a recovery disk in. SInce there's not even any evidence of a bios check, arguably it isn't even reaching the point of trying to start XP so it could be nothing to do with the attempted updates.

Any ideas will be gratefully received.

Thanks, ...Bernie

Like this post
Inside Edge

Likes # 0

Hi to all, and thanks fo ryou continued interest in solving my problem

Have spent a couple of evenings exploring your suggestions....

By way of clarification, ....The SATA HDD that I'm trying to boot to was installed 3 years ago and has worked p.erfectly until this power supply failure. It already has XP SP2 installed on it. When I originally installed the drive, I had problems getting the BIOS to see it. In fact I ran a thread on here for help. I got it working by installing it on the Promise RAID controller slot and configuring it as an independent drive rather than part of an array. For reasons unknown, I couldn't do the same on the VIA RAID controller on the board but hey, any way it worked was fine by me. I researched the old thread and also my own set up notes from the time and I see that you enable the Promise controller in the BIOS and then set it to "IDE Operating Mode" if you only want to attach a single HDD. This worked before and I've reset those settings. ....however it still won't boot to XP. It doesn't run off an IDE to SATA converter if you mean a separate PCI card but the Promise Controller in IDE mode may be doing just that.

In the BIOS Boot Device Priority, I now see; 1st Boot Device - 1st Floppy Drive 2nd Boot Device - SATA378 TX2 plus DO 3rd Boot Device - SM Sony CD-RW CRX300E

So it appears that the BIOS is seeing something. If I press ctl-F I can enter the Promise Fastbuild Utility for array assignments. If I then attempt to make a drive assignment, it succeeds and shows the model number of my HDD, correctly displays it's storage capcity and gives a status of "functional". I've deleted the assignment again because I'm not running an array, but it shows the drive is recognised by the Promise controller and presumably that means the Promise drivers are intact ....is that a safe assumption?

When I attempt boot up, the drive also shows up briefly when the Promise controller searches for drives.

The other change from default that I made in the BIOS was to disable the "onchip SATA bootROM" - I think this is for the VIA RAID controller so it shouldn't need to be enabled but in any case, I've tried booting with it enabled and disabled and neither works.

When I disabled the Promise Controller, I found I could boot to my Acronis Rescue Disk, however I can't select any of it's menu options !

I only have an OEM rescue disk from MESH so no Win XP disk. The OEM disk can only be used to reset to ex-factory set up so is no use.

So that's pretty much where I'm at now........

......any more ideas for the next step?

Thanks again

Like this post
Fruit Bat /\0/\

Likes # 0

Looks as if BIOS can see the drive therefore must be a problem with the boot files on the drive (maybe corrupted during the power failure.

Normal fix would be to do a XP repair from a XP CD.

Try downloading and burning an linux CD http://www.knoppix.com/

set the boot sequence to CD first Hdd second

boot the with the linux CD and see if you can access the data on the drive.

If the drive isn't totally corrupt then maybe you can copy the boot.ini file and NTLDR file, NTDETECT.COM file from a good XP to the bad drive.

Another option as you mentioned a floppy drive, is to make a floppy boot disk.

First format a Floppy disc

Run type Format A: /u

Then open Notepad and copy and Paste this

[boot loader] timeout=-1 default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS [operating systems] multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="First harddisk, first partition" /sos multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="First harddisk, second partition" /sos multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="First harddisk, third partition" /sos multi(0)disk(0)rdisk(0)partition(4)\WINDOWS="First harddisk, fourth partition" /sos multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Second harddisk, first partition" /sos multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Second harddisk, second partition" /sos multi(0)disk(0)rdisk(1)partition(3)\WINDOWS="Second harddisk, third partition" /sos multi(0)disk(0)rdisk(1)partition(4)\WINDOWS="Second harddisk, fourth partition" /sos C:\="Previous Operating System on C:\"

Save as

in Notepad as BOOT.INI

Then in search find

NTDETECT.COM NTLDR

Add these to the floppy disc

you can now try starting your computer with the floppy disc

Like this post
Inside Edge

Likes # 0

Hi Fruit Bat,

I think you're on the right track. I hooked up my old HDD (the one the SATA replaces) and I was able to boot to Windows with it. From windows I can see the SATA drive and access all the files on it. If I swap them over, I can't boot again so it does indeed look as though the boot sector on the SATA is corrupted. I think I've still got the MBR backed up on the old drive so I'll see if I can recover it to the new drive while booted from the old one. At worst I can retrieve any recent files not backed up.

...wish me luck !

Thanks once more, ...Bernie

Like this post
finerty

Likes # 0

tinker tinker sailor well done with the perseverance and patience hope all goes well with the pc. Try to get acronis and back up a copy to an external drive. do a backup of the hd once a month.

When a problem happens next time you wont lose the data u needed

Like this post
Inside Edge

Likes # 0

Hi to all who kindly contributed contributed resolution of my problem. Here's a belated update on the final outcome. I've been in the Middle East working and it's taken until today to execute thoes final steps.

As noted above, I was able to boot to my older, flakey HDD. From here I could see the newer HDD and access all the files on it, but wasn't able to boot to it. I spent a bit of time backing up key files, folders and software executables before taking further steps. I then made a new Image of the old HDD using Acronis ( I had an earlier one but I was being cautious). From this I restored the Master Boot Record and Track 0 (only) to the newer HDD. I swapped over the connections to make the newer HDD the boot drive, said a little prayer and ....bingo ! up she booted !

It should be noted that when I first bought the new HDD, I installed/formatted it it using an Acronis clone copy of the old drive. As such, the MBRs and track 0 were identical. I doubt this method of restore would have worked had this not been the case.

So the final diagnosis of my completely dead PC was a failed power supply which corrupted the Boot Sector when crashing the system. Well sussed Fruit Bat !

If we needed reminding, my experience has emphasised the value of back-ups. With Acronis, in the event of HDD problems, if you can boot to your CD drive, you can use the bootable rescue media to restore back-ups. I just used my old HDD instead.

Thanks again to all.........Bernie

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

LED vs Halogen: Why now could be the right time to invest in LED bulbs

IDG UK Sites

Christmas' best ads: See great festive spots studios have created to promote themselves and clients

IDG UK Sites

Why Apple shouldn't be blamed for exploitation in China and Indonesia