We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Problems setting up printer wirelessly


guyshahar

Likes # 0

Hello

I have just bought a Panasonic KX-MB2000 printer, and am trying to set it up so that I can use it wirelessly by connecting it to my router.

I plugged the USB end of the printer cable into my wireless router, and then went to my PC to add the printer from there, thinking that it would be detectable, but I could not find it.

The "Add New Printer" Wizard had 2 options - connect a new network printer, and connect a local printer attached to the computer. Neither accurately describes my situation. I do not have any sort of Network (where computers can share each others files and so on - and would not know how to start one up), I just want to be able to use the printer from one of my laptops or my phone without having it physically plugged into whichever machine I want to print from.

I tried the install network printer option, but when the wizard browses for a printer, it does not find anything. In the "Shared Printers" box, one item appears - "Microsoft Windows Network", but when I select it nothing happens.

I then tried the local printer option, but the machine was not listed in the menu that appeared. I could have put the disk straight into the machine and installed that way, but I thought that the PC should detect the printer before I do that, and I had no indication that it had.

I went to My Network Places and got a list of connections (no idea what most of them were, but they were all still there when I switched off the printer, so I guess none of them is the printer).

Am I missing something here, or doing something very stupid. I would have thought that it was relatively easy to set up a printer connected to a router. Am I overlooking something obvious?

Thanks for any help....

Like this post
difarn

Likes # 0

Have you tried:-

Connect your PC via ethernet to the router. Connect the printer to that pc check it is working correctly on that pc.

Then: 1. Got to control panel 2. Click printers and Other Hardware 3. Click view installed printers 4. Highlight the printer 5. On the left pane click Share this printer 6 Follow all instructions

You will need to have the printer installed on all pc's.

When completed you should be able to use the printer on all pc's attached to your network (the printer will now be connected to the router only.

If you have a pc attached to a router then you have set up a network.You do not say the OS of your pc but it is possible to set up a workgroup with pc's with different OS. This can be explored if you have problems setting up the printer on your router.

Like this post
Kennew

Likes # 0

If I got you correctly, You are connecting printer via USB cable to your Router.

Make Sure your Driver for your Printers are Installed.

Make sure your Computer is Connected via Wired(with Ethernet) or Wireless(using Wifi) to your Wireless Router.

You might need to Install the Software provided with your Wireless Router If you're trying to Connect with USB connection from Printer to Router.

Like this post
guyshahar

Likes # 0

Thank you Difarn.

I have followed all of the steps that you outlined, then I disconnected the printer from the PC and connected it to the router.

I then clicked "Add a Network Printer", and the Wizard this time did allow me to add the printer (I identified it by the name I gave it when I was setting up).

However, I am still not able to print when the printer is connected to the router, but not to the PC. It shows the printer as offline.

Can you please help me with this?

Like this post
guyshahar

Likes # 0

(BTW - it is now connected to the router via Ethernet, rather than USB)

Like this post
guyshahar

Likes # 0

(and as Kennew advised, I first installed the printer drivers and software off the CD, so that they were all there at the start of the process)

Like this post
difarn

Likes # 0

You didn't say that you had an ethernet connection. Usually printers are installed via the router by ethernet in the following sequence. If you do this it is best that you uninstall the printer from your PC.

Connect the printer to the wireless router using the Ethernet cable. Your PC also needs to be connected, either by ethernet or wireless.

Click on the "Printers" icon in the Windows Control Panel. Then click "Add Printer."

Select "Find a Network or Wireless Printer." Then click the "Next" button.

Insert the disk that came with the printer when prompted so that the computer can install the driver.

Click "Finish" after the drivers are installed.

If this is not successful:-

Try

right click on (Network)Printer , choose Properties , go to Ports tab, choose Configure Port , then un-check SNMP Status Enable option

My previous suggestion was via usb and plugging the printer in to the pc (and the pc by ethernet to the router) and letting windows 7 find the driver - not loading up the drivers first. This can make all of the difference.

Like this post
guyshahar

Likes # 0

Thank you Difarn

Maybe it is because I am setting this up using a laptop with Windows XP (I also have a Windows 7 laptop, but it is currently being repaired), but when I click to add a printer, there are 2 options:

1 - Local Printer attached to this computer (and it says I should select this if I am using a network printer not connected to a print server, but I'm not sure I understand what that means). If I choose this option, I am given a list of printers, which does not include mine. It says, "If your printer is not listed, consult your printer documentation for compatible software" - this does not help...

2 - Network Printer, or a printer that is attached to another computer. If I choose this option and browse for a printer, none comes up. In the list of Shared Printers, I see "Microsoft Windows Network", but nothing happens when I select it, and I am not able to click next without specifying a valid printer name.

Like this post
difarn

Likes # 0

Ok - to install a printer on your router network requires the IP address of the printer and you have to add a port.

Have a look at this step-by-step article, with images.You will be choosing Local Printer. Uninstall any reference to the printer on your PC before you start.

When this is complete, and working, it will be necessary to have the printer drivers installed on each PC on the network.

Like this post
difarn

Likes # 0

Ok - let's try deleting the printer from your laptop.

Connect the the printer via ethernet to the router (the printer should also be connected to power); it should assign an IP address to the printer automatically.

On your laptop go to the control panel and click on Printers and Devices. Then click Add Printer. Select add Network Printer and it should find the printer network as it's IP address is in the same pool as your network.

Select the printer and it will then try to connect to the printer. At this point, it will start to ask for Drivers. Click on the "Have disk" button and go to the Printer Drivers CD and install- this will automatically detect the signed drivers for the printer. It will then install the drivers that are needed.

Like this post
difarn

Likes # 0

Please ignore the first post - posted in error.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

45 Best Android games: top Android games for your smartphone or tablet in 2014 (24 are free!)

IDG UK Sites

How Apple, Adobe, Microsoft and others have let us down over UltraHD and hiDPI screens

IDG UK Sites

Do you have the X-Factor too? Mix Off app puts fans in the frame

IDG UK Sites

iPad Pro release date, rumours and leaked images - 12.9 screen 'coming in 2015'