We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
 
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Very slow internet connection since restoring to new HDD


Pineman100

Likes # 0

I recently suffered a hard drive crash on my Windows 7 Home Premium laptop. With a great deal of help from Fruit Bat /\0/\ on this forum, I fitted a new HDD and restored my entire system to the new drive from my Acronis True Image 12 backup on an external HDD.

All is now well with my system, except one thing. Since the above event, my internet connection has become - randomly - desperately slow.

When I first launch my browser, Firefox 10.0.2, in the morning, it takes ages to start up and go to my home page (Google). When I then go to Google Mail, it takes an equally long time to display my mail page.

But this symptom seems to be random. Sometimes when I click from one website or page to another, the response is as quick as normal. At other times it takes a very long time - between 30 seconds and a minute is not unusual. I've tried to identify some pattern in the randomness, but I just can't.

Any ideas, please?

Like this post
Nontek

Likes # 0

Try resetting your Router - switch it off, wait at least ten seconds then switch it on again. Give it a couple of minutes to settle down.

Like this post
finerty

Likes # 0

pineman if you can use a friends computer and go to U tube find out about:config on firefox ff

just type in U tube how to speed up firefox 8x and twiddle with the setting in ff.

Im sure if you should try defrag the drive or clean the junk using acronis or CC might help.

Like this post
onthelimit1

Likes # 0

For interest, what's it like with Chrome or IE?

Like this post
Pineman100

Likes # 0

Thanks for those responses.

Nontek - I did a router (BT Home Hub) reset a few days ago to try and solve the problem. I just tried again, but no improvement I'm afraid.

finerty - thanks for those suggestions, which I'll try. As a matter of interest, doesn't Windows 7 defrag itself automatically?

onthelimit1 - the problem is no better in IE. I don't have Chrome.

Like this post
Woolwell

Likes # 0

How are you connecting to your router? What is your download speed? Any exclamation marks in device manager? Which anti-virus? How much ram?

Like this post
Pineman100

Likes # 0

Thanks for your response, Woolwell.

I connect to my router via wi-fi 802.11g (My BT Home Hub actually has 802.11n but my laptop hasn't).

PCA Speed Test results (a couple of minutes ago) are: download 2.74 Mbps, upload 0.36 Mbps. Fairly normal for my location.

There are two exclamation marks in Device Manager, both under "Other Devices"

  1. EASEUS Disk Enumerator. The drivers for this device are not installed (Code 28). I have no idea what this device is.
  2. Unknown Device on Port#0002.Hub#0001. The drivers for this device are not installed (Code 28). Once again, I don't know what this is.

My antivirus is Norton Internet Security, which reports no problems. However, you have reminded me that only a couple of hours before my system crashed I had downloaded a free upgrade from NIS 2011 to NIS 2012. Do you think there's any significance in this?

I have 4GB of RAM and a Windows Experience Index of 4.1.

Any thoughts, please?

Like this post
Woolwell

Likes # 0

Guess that you have EaseUS backup. It would appear that it didn't properly install. See Easus forum Under Task Manager do you have any processes using the disc in the background. A long shot it could be that system is trying unsuccessfully to to do a back up.

Wait for others for the other unknown device.

I would think that the system crash and download of the update is coincidence.

Like this post
Woolwell

Likes # 0

ps - Is Norton doing a background scan as that can slow things up.

Like this post
finerty

Likes # 0

pineman ive just come across this that might help

speed up internet

Like this post
Pineman100

Likes # 0

Woolwell - thanks for those thoughts. No, I checked whether a background scan is going on, and it's definitely not. And I can't see anything in Task Manager that's making any ongoing disk demands (drive light also not showing undue activity).

Thanks for the Easeus advice. I'll try to get it uninstalled - I never use it and don't really know why it's there.

finerty - thanks for that link. Do you know for sure that Full Speed is genuine and safe?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Amazon 3D smartphone release date, price and spec: The hologram phone?

IDG UK Sites

iPhone 5s review: why the iPhone 5s is still the best phone you can buy in 2014

IDG UK Sites

Passwords don't work: here's four ways to fix them

IDG UK Sites

Developers get access to more Sony camera features