We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Speaker connection via USB Hub


Biko59

Likes # 0

I have bought a pair of speakers with built in amplifier for my laptop which plug into the USB port. They work perfectly when plugged direct into the laptop, however, they don’t work when plugged in via my 4 port Powered USB 2.0 Hub. Why might this be please?

Like this post
difarn

Likes # 0

It sounds as if the speakers are not getting enough power via the powered hub or there is a conflict with other devices. Have you tried...

Connecting the powered hub to another usb socket? Connecting your speakers to the hub after boot up - or if you do this already try them plugged in before boot up.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Sony Xperia Z3+ release date, price and specs: The Xperia Z4 for the UK

IDG UK Sites

Why Intel’s vision of the future is a future I want to live in

IDG UK Sites

10 amazing, creative uses of tech – and the brands behind them

IDG UK Sites

Jony Ive 'semi-retired' into new role: kicked upstairs as Chief Design Officer