We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Using the Soundcard as a Source for Recording Streamed Music


thegreypanther
Resolved

Likes # 0

I am wanting to record streamed music on my PC (now using Audacity as the software).

However, the only options I have for the input are a) the Microsoft Sound Mapper and b) the microphone on my webcam. No mention of the soundcard on its own (Realtek).

I always thought that you could stream sound directly from the soundcard. If so, can anybody give me tips on how to set things up please.

I'm using a Windows 7 64-bit PC.

Grateful for any hints or tips.

Like this post
rdave13

Likes # 0

Right click the speaker icon in the notification area and select 'Recording Devices'. See if you have 'stereo mix' or 'what u hear' in the list.

Like this post
rdave13

Likes # 0

Just remembered your other post about trying to record using a dodgy software.

I did the same but used another one which wasn't quite as bad, Can't remember it now. What I eventually did was to update the sound driver to get stereo-mix available in the sound properties. If you're sure it's Realtek (High-Def)then I used this driver on Win7 64-bit and works a treat, link

Like this post
rdave13

Likes # 0

Latest driver here but the older one works for me.

Like this post
thegreypanther

Likes # 0

rdave13.

Many thanks, but even with the updated RealTek driver installed I'm still drawing a blank.

In Audacity I'm only given two options for recording.

Primary Sound Capture or Microphone

There is a choice of interface, - Windows Direct Sound or MME (whatever that is).

In the RealTek Audio manager, everything seems to be geared to playback. Nothing about iput.

I give up!!

Like this post
thegreypanther

Likes # 0

SUCCESS!!

I persevered and read through Audacity's instructions in http://wiki.audacityteam.org/index.php?title=MixerToolbarIssues#UsingtheControl_Panel

The trick is that in Windows 7 the "Stereo Mix" option is removed from the Sound Options - Recording in the Control Panel.

If you go into this box and right-click then Stereo Mix is presented to you. Select this and away you go!!!

Once this is set up in the Control Panel, then select it in Audacity's list of recording devices. Works brilliantly!

Like this post  

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Black Friday 2014 tech deals: Get bargains on smartphones, tablets, laptops and more

IDG UK Sites

What the Internet of Things will look like in 2015: homes will get smarter, people might get fitter

IDG UK Sites

See how Trunk's animated ad helped Ade Edmondson plug The Car Buying Service

IDG UK Sites

Yosemite tips: Complete Guide to OS X Yosemite