We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Streaming problem


Ian in Northampton

Likes # 0

I have two PCs, both connected wirelessly to the same router. One is a 2.8GHz P4 with 2GB of memory, running XP. The other is a Dual core 2.6GHz E5300 with 3GB of memory running W7 Home Premium. The latter streams flawlessly - the former very poorly, with regular video freezes. Given that we can eliminate my Internet and wi-fi connection as the causes - the W7 machine is fine - where should I be looking to try to find the cause(s) of the XP machine's poor streaming performance?

Like this post
T0SH

Likes # 0

From my reading of your post you can eliminate your your Wireless router and your Win7 wireless connection as being the problem, but the XP wireless connection cannot be eliminated quite yet

Why not try a few speed tests from here on both machines alternately if the results turn out to be reasonably close then, you can eliminate wireless issues as the problem

http://www.speedtest.bbmax.co.uk/

It is always worth eliminating any bandwidth stealing utilities which start with windows in diagnostic tests on streaming issues

A handy tool to help identify the culprits is the free utility called What`s Running combined with something like Autoruns or its likes should give you the ammunition you need

http://www.whatsrunning.net/

Cheers HC

Like this post
Woolwell

Likes # 0

What anti-virus/firewall do you have running?

Like this post
Ian in Northampton

Likes # 0

Thanks guys.

TOSH: great idea - I hadn't thought of independently verifying the speed of the two connections. However, it turns out they're pretty much identical at just under 6Mbps (I was surprised it was so high).

So, on to "what's running". Fascinating stuff, although I can't claim to understand it all. One thing did pop out at me, though. On the W7 machine (the 'good' one) I have between 50-70 IP connections running. On the XP machine, there are more than 4,000!

Closer examination reveals that the huge majority of these are HPNetworkComunicator.exe. These are doubtless there because of my wireless HP printer - but why there should be so many I have no idea (other than the printer has been attached via cable for a while, as the wireless connection proved flaky, so it may generate a new IP connection every time the PC polls the printer).

However, I doubt that's the source of the poor streaming, as streaming has been bad since before I installed the HP printer.

There are also some slightly troubling IP processes that are associated with e.g. Akamai Technologies and Expert City.

Also - I can get "what's running" help to initialise - do you have any insight as to why, occasionally, some of the IP processes get highlighted in red, and sometimes in green?

Woolwell: on the XP machine, it's Avast! - on the W7 machine, it's MSE.

Like this post
Woolwell

Likes # 0

Just wondered if the streaming is being scanned by the anti-virus and how much resources those programs are using. This may be a red-herring.

Like this post
Ian in Northampton

Likes # 0

Thanks Woolwell. I can't be 100% certain, but I think the streaming problem was apparent from before I switched from AVG to Avast.

Like this post
Secret-Squirrel

Likes # 0

Ian, where does the streaming problem occur? Is it with BBC iPlayer on the web, BBC iPlayer desktop application, YouTube, or everywhere? If it's browser-based streaming that's affected, then does the same problem occur in more than one browser?

When the video freezes, do you see the little circular animation centre-screen to indicate the player's buffering data?

To start you off with some practical advice, it may be worth you running a fuller set of tests - BBC iPlayer Diagnostics would be ideal as apart from the regular speed-checker, it's also incorporates three streaming tests. Compare the results from both PCs and let us know what you find.

Like this post
Ian in Northampton

Likes # 0

S-S: thanks. It's everywhere - anything I try to stream suffers the same. However, I wasn't aware of the iPlayer diagnostics, so I'll definitely give those a try.

Like this post
Secret-Squirrel

Likes # 0

How did you get on with your streaming tests Ian?

If again you got roughly the same results on both PCs then here are a some things to try (in the order listed):

1) For Flash-based videos, such as YouTube, or the browser-based iPlayer etc, right click in the video window, choose "Settings..." and experiment by toggling the "Enable Hardware Acceleration" option.

2) From the right-click menu, choose "Global Settings" -> "Advanced" tab. Click the "Delete All" button to empty the cache and remove any custom settings.

For suggestions 1 and 2 I'd recommend restarting your browser after making any changes.

3) Right clicking again will also show you the Flash version at the bottom of the menu. If the Windows XP one is older than the one used on your Windows 7 PC then you may want to consider upgrading it from HERE.

Like this post
Ian in Northampton

Likes # 0

S-S: many thanks. Yep, I tried the iPlayer tests, but they revealed nothing that helped. So, on to your next set of suggestions. Very many thanks.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Windows 9 release date, price, features: Windows 9 beta leaked ahead of 30 September unveiling

IDG UK Sites

Is Apple losing confidence in itself?

IDG UK Sites

The Samsung Gear VR is better than the Oculus Rift (kinda)

IDG UK Sites

How (and where) to buy an iPhone 6 or iPhone 6 Plus in the UK. Plus: How to buy an iPhone 6 today