We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Save a laptop from the scrapheap!


noddy1

Likes # 0

For the last 4+ years we have been using a HP Presario C300 laptop as our family home computer. Then a couple of weeks ago when we turned it on and it started to boot into Windows XP the screen suddenly went blue and the following message came up:

A problem has been detected and windows has been shut down to prevent damage to your computer. UNMOUNTABLEBOOTVOLUME Technical Information: * STOP:0x000000ED (0x85BE6E30, 0xC0000185, 0x00000000, 0x00000000)

Now I am not super competent when it comes to PCs but I guessed this was probably a simple HDD failure. So I thought I would go onto eBay to buy an identical one.

The faulty drive in question is (according to the main print on the unit) a: Momentus 5400.2 80GB SERIAL AT DISC DRIVE. In even smaller print it says the model is a: ST98823AS

When I was looking at similar drives on eBay it seems most folks were just describing them as ‘Momentus 5400rpm 80GB’ hard drives, so I assumed this was exactly what I needed… and it still may be.

So I brought one on eBay and popped it into our old HP laptop when it arrived. I wasn’t really expecting it to boot into Windows since I assumed it was a formatted drive. But just in case I switched on the laptop.

On the screen the following message came up:

Intel UNDI, PXE-2.0 (build 082) Copyright © 1997-2000 Intel Corporation For Realtek RTL8139(X)/810X PCI Fast Ethernet Controller v2. 13 (020326) PXE-E61: Media test failure, check cable PXE-MOF: Exiting PXE ROM.

Then the same message above would repeat over and over.

So then I thought I would just install XP from a CD-ROM and I let the Setup go through its normal process, until that it is came up with the following screen:

"Setup did not find any hard disk drives installed in this computer."

So then I assumed I must have been sold a faulty HDD on eBay. But before going back to the seller I decided to try the drive in an external HDD housing/case I have sitting around. With the new HDD plugged in via the connectors inside the case I was able to access the drive and write and read data to/from it.

So then I thought let’s try the same thing with the original drive from the laptop. This time I could not access the drive at all (well actually the main partition, in fact I could access the XP recovery partition that HP put on). When trying to access the main partition I ended up with an hourglass icon and eventually it locked the PC I was trying to access it from.

So at this point I assumed the original HDD was faulty and the new one is working, but for some reason it won’t work in the laptop.

Finally I decided to compare the information on the back of the new drive with the old one.

Here are the differences:

Old drive: : Momentus 5400.2 80GB SERIAL AT DISC DRIVE. Model: ST98823AS New drive: Momentus 5400.3 80GB SERIAL ATA DISC DRIVE. Model:ST980811AS

I’m not sure why the old one only shows AT and the new one ATA, nor the difference of .2 and .3

However I also noticed (but it may not be relevant) that the new drive had a Lenovo part number on it as well, so I assume it came out of a Lenovo laptop. Coincidentally I happen to know that many Lenovo laptops have a small solid state drive to assist in their patented ‘Rapidboot’ process.

It works in conjunction with the main HDD. But this might just be a red herring.

So can anyone shed some light on all this? Are these hard drives actually different and do I need to get the right one or is there another reason why the laptop doesn’t like this new HDD even though it appears to be working via another PC?

Thanks for any advice.

Like this post
Fruit Bat /\0/\

Likes # 0

Have you retried it in the laptop since you have written data to it?

Like this post
Fruit Bat /\0/\

Likes # 0

Old drive

  1. Start your computer by inserting the Windows startup disks or the Windows installation disk if your computer can start from the CD drive.
  2. When the Welcome to Setup screen appears, press R to select the repair option.
  3. If you have a dual-boot or multiple-boot computer, select the Windows installation that you want to access from the Recovery Console.
  4. Type the administrator password when you are prompted to do this.

    Note If no administrator password exists, press ENTER.

  5. At the command prompt, on the drive where Windows is installed, type chkdsk /r, and then press ENTER.
  6. At the command prompt, type exit, and then press ENTER to restart your computer.
  7. After you repair the volume, check your hardware to isolate the cause of the file system damage.
Like this post
noddy1

Likes # 0

Thanks Fruit Bat. I tried what you said and I am getting the same message as the new drive just after pressing R, ie:

"Setup did not find any hard disk drives installed in this computer."

Like this post
Fruit Bat /\0/\

Likes # 0

insert new drive

boot to BIOS and try a manual search for the drive.

also check ACHI is enabled in BIOS

Like this post
rdave13

Likes # 0

Reading you first post again, you look like you're having multiple failures, so I suspect the motherboard is failing.

Like this post
robinofloxley

Likes # 0

I wrote a lengthy ish reply which I saved, cos I didn't want to muddy the waters and wait in case other ideas were tried.

Anyway, I think a new CR2032 button battery for the BIOS might be worth a try. (supermarket battery section may have one). That's for the non-recognition of the new drive maybe.

Then...what I was going to post earlier....

Nothing should go to the scrapheap or return to seller yet.

Put your old drive with unreadable partition in working computer.

Open Windows Explorer/My Computer and right click the unreadable partition. eg F: or whatever.

Select Properties/Tools Tab/Check Now for errors.

If that doesn't work, Start Run diskmgmt.msc , right click the partition and delete it.

Right click the Unallocated space and Create new partition.

If that works, your old drive is still working but nothing on it save the Recovery partition.

Download Partition Wizard. Install and run. Right click the Recovery Partition on the old drive and Modify/Set Active.

OK/Apply. Put the old drive back in the laptop.

It should boot to the Recovery Partition and Restore back to Factory condition.

You will then have some hours of Windows updates. This download for SP3 may save some time.

Like this post
noddy1

Likes # 0

OK, I've had some success... but I'm not too sure why. What I did was change the Sata option in the Bios from Enable to Disable and from that point on the laptop would see the HDD and I've been able to install XP.

So problem solved re the new HDD.

If anyone has advice on how to recover the data off the old HDD then I am happy to try it.

Thanks for the time and effort made by folks so far.

Like this post
onthelimit1

Likes # 0

To recover data, put hdd into one of these then you can access it from your laptop. I believe your old drive is SATA. If not, there are similar devices available for IDE drives.

Like this post
Fruit Bat /\0/\

Likes # 0

have you tried putting the old drive back in and running chkdsk

or do as robinofloxley has started with the drive coupled to another PC

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

45 Best Android games: top Android games for your smartphone or tablet in 2014 (24 are free!)

IDG UK Sites

How Apple, Adobe, Microsoft and others have let us down over UltraHD and hiDPI screens

IDG UK Sites

Do you have the X-Factor too? Mix Off app puts fans in the frame

IDG UK Sites

iPad Pro release date, rumours and leaked images - 12.9 screen 'coming in 2015'