We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Epson Stylus Office BX525WD


Thereferee21

Likes # 0

I cannot get the above all in one to work wirelessly after setting it up on my laptop it says it is a network printer but nothing happens. Any ideas please

Like this post
northumbria61

Likes # 0

Open Network and Sharing Center by clicking the Start button , clicking Control Panel, clicking Network and Internet, and then clicking Network and Sharing Center. Click the arrow button next to Printer sharing to expand the section, click Turn on printer sharing, and then click Apply. Your printer is now shared on the network. Administrator permission required If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

Like this post
Thereferee21

Likes # 0

Hi,

I got as far as the net and sharing centre but did not see printer sharing or an arrow to expand the section.

Where did i go wrong?

Cheers

Ian

Like this post
Woolwell

Likes # 0

Is the printer set up with your wireless network and the wireless light on on the printer?

How did you set it up? It is important to follow the instructions exactly. Did you follow the network guide? Epson support

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Galaxy Alpha vs iPhone 5S comparison review: Metal smartphones fight

IDG UK Sites

Gateway to your kingdom: why everybody should check and update their broadband router

IDG UK Sites

Fonts review

IDG UK Sites

Best Mac? Complete Apple Mac buyers guide for 2014