We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

External Hard Drive Stopped showing in 'My Computer' on pc


kat64

Likes # 0

Hi, I bought a 2Tb Envisage External USB Hard drive in February 2011 and it has been working fine until this week. It has suddenly stopped appearing in 'My Computer' so that I cant access the Contents. I run Windows 7 but even so I tested for driver updates which are all OK. In Device Manager it only shows up under 'Universal Serial Bus Controllers' and it is shown as Working properly. I have tried installing on a Vista laptop but its the same problem. Can anyone please help. Kind Regards

Like this post
rdave13

Likes # 0

Go to Disk Management by right clicking Computer in the start-up list then select Manage then disk management. You should be able to work out which is the usb drive. Right click it and select 'change drive letter and paths....' I suggest you select a letter at the end, or near, of the alphabet.

Like this post
rdave13

Likes # 0

PS, never remove a USB peripheral without using the safely remove wizard if showing in the notification area.

Like this post
kat64

Likes # 0

rdave13. Thanks for answering to my problem. I have done what you suggested but when I right click on the USB drive concerned I don't see the option for changing the drive letter & Paths. All I get is: Update Driver Software,Disable, Uninstall,Scan for H/Ware changes, Properties. Can you suggest anything else.

Like this post
rdave13

Likes # 0

If you have important data on the drive we're on dangerous grounds here. So the first option I would suggest is to find an XP machine you could use and to connect the USB drive to that. See if XP has any problems, if not then backup all data if you can.

In properties, second option, select tools and select error checking, select the error checking tab and tick both boxes, select apply then when asked to dismount drive select no apply then accept to check the disk on reboot. Leave the usb drive connected.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best January sales 2015 UK tech deals LIVE: Best New Year bargains and savings on phones, tablets,...

IDG UK Sites

Chromebooks: ready for the prime time (but not for everybody)

IDG UK Sites

Best Photoshop Tutorials 2014: 10 inspiring step-by-step guides to creating amazing art,...

IDG UK Sites

Mac tips tricks & hacks: 10 things you didn't know your Mac could do