We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:

PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom

It's free to register, to post a question or to start / join a discussion


PC only running at 1/2 speed


Likes # 0

I bought a second hand PC which was reported to have a 2.8GHz processor.

As it also had a 256MB Video card, I bought games that would run on that spec.

Trying to run the games wasn't very successful as they ran extremely slowly.

I've done some investigation and the Device Manager in Windows shows it as a 2.8GH Pentium 4 processor but, when I start up, the BIOS reports it as a 1.4GB processor. In addition, a tool I downloaded confirmed that it was running as 1.4GB.

I am confused as to how the PC can report 2 different speeds and if I can enable the faster speed somehow.

Any help would be appreciated!


Like this post

Likes # 0

Hello again,

Thanks again for all your help!

The Bios on my machine is by Phoenix technologies, BIOS version 6.00 PG. The CPU has a Northwood core I've tried disabling hyper-threading in the BIOS and loading the Default and Optimised settings and these have made no difference. The CPU clock speed still shows as 100.3 MHz.

Task Manager only shows 1 graph of CPU history when, from what I have read online, I was expecting it to show 2. Could this mean that the hyper-threading isn't working anyway.

The BIOS shows the FSB and multiplicator settings but doesn't let me amend them.

I've downloaded some other utilities but none of these seem to let be reset the CPU Clock either.

However, one does show several graphs of CPU Load etc. and one of these refers to CPU Core Clock and Throttle, both of which are set to 1403 MHz.

I read that XP includes a Throttle function to protect against overheating. Could this mean that I have a cooling problem and that is limiting the CPU speed?

SIW appears to be showing min/max temps of 37 and 39 degrees Celsius.

I am getting increasingly frustrated!


Like this post

Likes # 0

Don't know what utilities you've downloaded to help you with your problem, maybe cpuz

enter link description here

Have you tried throttle watch with you mentioning throttling, will show any P4 throttling

enter link description here

Everything showing OK in device manager? Was wondering about a bios update, or whether there were jumper settings on the motherboard that set fsb?

Seen this site mentions your motherboard Ultra Version 1.5a and your chipset SiS648, seems you download the software and install it ito run at startup, however it's at your own risk

enter link description here

also "overclocking" software like ClockGen but at your own risk. Sorry ideas only, not much help.

Like this post

Reply to this topic

This thread has been locked.

IDG UK Sites

LG G4 Note UK release date and specification rumours: Samsung Galaxy Note 5 killer could be the LG 3......

IDG UK Sites

In defence of BlackBerrys

IDG UK Sites

Why we should reserve judgement on Apple ditching Helvetica in OS X/iOS for the Apple Watch's San...

IDG UK Sites

Retina 3.3GHz iMac 27in preview: Apple cuts £400 off Retina iMac with new model