We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
 
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Windows Explorer 9, - Problems Loading Javascript Pages in New Window


thegreypanther

Likes # 0

I find that I cannot open a page in Windows Explorer 9 that contains Javascript, if that page is one that opens as a new page from another page.

An example is a slideshow which opens from a main page,- http://www.enicholl.com/priory-friends/html-files/visits-photo-gallery/photo-gallery-visits-2011.htm#advent There is no problem opening such a page in Firefox or Chrome (my browsers of choice).

I gather this problem has something to do with "ActiveX controls", - whatever they are. Any ideas how to get round this, please. I don't like Windows Explorer 9, but other people use it so websites such as that mentioned above need to work.

Like this post
buteman

Likes # 0

Do you mean Internet explorer 9 and have you downloaded the latest java update.Make sure it is enabled in add-ons and you are using the 32Bit and not the 64Bit version of Internet explorer.

Like this post
buteman

Likes # 0

Works Ok for me using IE8.W/7.It could be an active exe problem like you say but not sure how you would fix it .I dont suppose you get a dropdown bar wanting you to use the add-on

Like this post
thegreypanther

Likes # 0

This gets confusing. Yes, I am using Windows INTERNET Explorer 9. But I have a 64-bit PC so presumably am using the 64-bit version of IE9. I'll check about having the latest Java update. But it seems odd that things work fine in Firefox and Chrome but not IE9.

Like this post
buteman

Likes # 0

Go into All programs and there should be 2 versions of I/E do not click on the 64Bit one use the other one.

Like this post
thegreypanther

Likes # 0

Just tried the 32-bit version of IE9 as recommended. Still won't open a new page, as above, that contains Javascript.

Like this post
buteman

Likes # 0

Looks like there is a 64 Bit version as well.

you can press verify and that will tell you what version you have.

But I believe there is a tool on that page that will remove all versions.

Then maybe go to Safe mode with networking and download the latest version from there.

http://java.com/en/download/manual.jsp

Like this post
buteman

Likes # 0

Ignore last.You cannot download it in safe mode.So just download it with normal start.

Like this post
rdave13

Likes # 0

Works fine for me in IE9 64-bit. Check JavaScript is enabled. In IE select tools, internet options,security tab, custom level button, and in internet zone, displayed, scroll down to scripting section. Locate active scripting and make sure 'enabled' is selected. Select OK.

Like this post
thegreypanther

Likes # 0

I give up.

Active scripting is enabled, and still my IE9 won't open the page in a new window.

If the URL of the page is entered into the menu bar on its own, however, the page opens up.

I've tried this for other webpages where, say, there is a link to a Guest Book page wich opens in a new window. The page won't display by selecting the link, but WILL display if the page URL is entered.

e.g a page wihich includes Javascript won't display if the link to it makes it a new page.

Like this post
thegreypanther

Likes # 0

Many thanks, 124.

Unfortunately, no suggestion tried works, as yet!

For the time-being, I'm just to give this up as a bad job. I normally don't use IE9 any more than I can help, but I need to sort this one out simply because the problem occurs on a website I run for a church, - and I don't want the people using that website to experience the same problem.

My next tack will be to run IE9 on another computer and rigorously compare security settings.

Should I find the answer to this problem, I will certainly post it here!

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Gear 2 review: Classy Tizen smartwatch is too expensive

IDG UK Sites

Eight possible names for the next version of Mac OS X: What will Apple call the follow-up to Maveri?......

IDG UK Sites

Why our gadgets will kill us all: bleating notifications, too many chargers and the proliferation...

IDG UK Sites

Inside Twitter's new design and ad offerings