We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Firefox 8 dead slow!


Ikarus

Likes # 0

I have downloaded FF8 and find that pages take an age to load - the notification is always "waiting for..." Eventually the page loads but elements on the page can then take a long time to load. I never had this with FF7. I am running Win7 Home Premium with 4GB of RAM. If I use Google Chrome browser everything loads quickly using the same pages as for FF8 and the same wireless router.

I also have a Netbook running Win7 Home Premium and FF8 using the same wireless router. This works perfectly with little or no delay on the same sites and pages.

Is this FF8 or is there something that I have missed? Thought and possible causes received with thanks.

Like this post
Graphicool1

Likes # 0

Hi

I'm running FF8 - Win7 - 4GB Ram - No problems.

My FF Extentions are: AdBlock Plus 1.3.10 & Avast! WebRep 6.0.1289

Give us some examples of websites that FF is slow to load/run.

Like this post
Ikarus

Likes # 0

Two sites which have caused problems are Amazon and Marks and Spencer. In both cases the information at the bottom of the screen shows "waiting for ecx.images-amazon/marks and spencer.com" The computer sceen is blank for most of the time but after a minute or more most of the page loads but the waiting for"ecx images" etc is still shown for another minute or so. Because it takes so long to load pages I have swapped over to Google Chrome or used the Netbook. I would prefer to use FF8 as I have used FF for some years without problems.

Like this post
Woolwell

Likes # 0

Both sites work fine for me with FF8.

Like this post
Graphicool1

Likes # 0

For me both sites came up in the blink of an eye.

Perhaps you should think about uninstalling FF8 and reinstalling.

Like this post
Ikarus

Likes # 0

I have uninstalled FF8 twice (using Revo uninstaller) and re-installed it with no improvement. I have now downloaded and installed FF7 but this has not cured the problem. Thanks for your comments and suggestions. I also find that typing in a search item and using Google or Yahoo results in a massive delay in displaying anything on the screen. Perhaps I will have to persue my internet connection with my ISP - BT.

Like this post
Ikarus

Likes # 0

having sent the last reply I had a warning that AVG had detected high memory usage by FF of 267mb. It suggested closing FF and starting again.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Black Friday 2014 tech deals: Get bargains on smartphones, tablets, laptops and more

IDG UK Sites

What the Internet of Things will look like in 2015: homes will get smarter, people might get fitter

IDG UK Sites

See how Trunk's animated ad helped Ade Edmondson plug The Car Buying Service

IDG UK Sites

Yosemite tips: Complete Guide to OS X Yosemite