We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

No Autoplay when DVD in drive, options to 'Open', 'Explore', etc


bob dob

Likes # 0

Hi, when i insert a DVD into my external DVD drive, the only options that appear on 'My Computer' are Open,Explore, CD check etc. Also it appears as a CD Drive when it is a DVD drive. Please can i ask where the autoplay option has gone and how i can get it back? Thank you.

Like this post
Fruit Bat /\0/\

Likes # 0

XP?

one of the latest upgrades removed auto play form all except internal DVD drives for security reasons.

the disk also must have an autoplay file on it

Autoplay Repair Wizard http://www.microsoft.com/downloads/details.aspx?FamilyID=c680a7b6-e8fa-45c4-a171-1b389cfacdad&DisplayLang=en

Autoplay disable/enable 1. Click Start, click Run, type regedit in the Open box, and then press ENTER. 2. Locate and click the following registry key: HKEYLOCALMACHINE\System\CurrentControlSet\Services\CDRom 3. To disable automatically running CD-ROMs, change the Autorun value to 0 (zero). To enable automatically running CD-ROMs, change the Autorun value to 1. 4. Restart your computer.

If Autoplay does not work in XP, here's another fix:

Run Regedit Go to HKEYCURRENTUSER\ Software\ Microsoft\ Windows\ CurrentVersion\ Policies\Explorer. Delete the Key "NoDriveTypeAutoRun" Reboot the Computer.

Vista Autorun problems:

Ensure that Shell Hardware Detection service is running

Type “services.msc” in Start Search to run Services console. Locate Shell Hardware Detection, and ensure that the “Service Status” is Running, and “Startup Type” is Automatic. If not, start the service and change the Startup Type setting accordingly.

Ensure that CD-ROM AutoRun is not disabled in registry

For users facing AutoRun/AutoPlay doesn’t work when insert a disc into optical drive, run Registry Editor (regedit), and navigate to the following registry subkey:

HKEYLOCALMACHINE\System\CurrentControlSet\Services\CDRom

Locate the AutoRun registry value in the right pane, and check that the value data for AutoRun is set as 1 (one), which is enabled. If it is 0 (zero), which mean disabled CD-ROM or DVD-ROM drive AutoRun process, re-enable the AutoRun by changing the value to 1.

Ensure that correct NoDriveTypeAutoRun and/or NoDriveAutoRun policy value is set

NoDriveTypeAutoRun registry key is used by Group Policy to configure whether to disable the Autoplay feature on all drives of the type specified. To check this setting, run Registry Editor (regedit), and navigate to the following registry key:

HKEYLOCALMACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

or (note that above registry value, if exists, will always supersede the below user-specific key),

HKEYCURRENTUSER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Locate the NoDriveTypeAutoRun registry entry on the right pane. The registry key is in DWORD hexadecimal value, which each bit determines which type of drive to disable or enable AutoPlay feature. There are many possible value for NoDriveTypeAutoRun, some possible wrong value that disable AutoPlay are:

0×000000B5 (181) disable AutoRun on CD-ROM drives, plus default unknown drive, removable drive (meant for floppy or ZIP), network drive and reserved drive type.

0×000000FF (255) disable AutoRun/AutoPlay on all drive types.

The best bet is to set NoDriveTypeAutoRun to default value as set by Windows Vista, which is 0×00000091 (hexadecimal) or 145 (decimal). Previous Windows version such as XP uses 0×00000095 (hexadecimal) or 149 (decimal). To enable AutoPlay on all drive types, set NoDriveTypeAutoRun to 0 (zero) or 0×00000080 (128) which only disable AutoPlay on unknown reserved file type.

NoDriveAutoRun registry key, which stored at the same registry location, meanwhile determine whether a particular connected drive should run AutoPlay function or not. When AutoRun is enabled on the drive, media is automatically started when it is inserted in the drive.

By default, Windows Vista does not add any NoDriveAutoRun registry subkey. And you probably don’t want to block any drive from AutoPlay too. So remove and delete all NoDriveAutoRun key in the registry.

Uninstall conflict software

Some software application, especially disc imaging or image editing program such as Nero, PowerISO, MagicISO, and even some other programs such as Rhapsody and various VMWare virtualization products such as VMWare Server and VMWare Workstation.

If you’re facing the drive won’t Auto Play or Auto Run issue after installing certain software, try to uninstall the software to see if it fixes the problem. Better still if it’s possible to roll back the system using System Restore to earlier Restore Point when the software is not yet installed.

Some laptops have the facility to turn off the card reader etc to save power... but it's done via a manufacturer specific utility that is installed along with Windows.

Like this post
gengiscant

Likes # 0

Like this post
bob dob

Likes # 0

Hi and thank you again Fruit bar, I've got to 'HKEYLOCALMACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer' here: http://i199.photobucket.com/albums/aa214/craigten/REGREG.jpg

and am not sure what to do now? (sorry for this)

Like this post
bob dob

Likes # 0

Sorry, i meant to say it's Vista!

Like this post
Fruit Bat /\0/\

Likes # 0

that key does not exist in you image so move onto

HKEYCURRENTUSER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Locate the NoDriveTypeAutoRun registry entry on the right pane. The registry key is in DWORD hexadecimal value, which each bit determines which type of drive to disable or enable AutoPlay feature.

then follow the rest of my previous link.

Like this post
bob dob

Likes # 0

Sorry for this, after HKEYCURRENTUSER\Software\Microsoft\Windows\CurrentVersion\Policies i only have the option of 'Associations' but no 'Explorer'??

Like this post
Fruit Bat /\0/\

Likes # 0

OK forget the reg entries then it just means that there is no group polices set to disable Autorun

http://vistasupport.mvps.org/autorunautoplaydon%27tworkwhencddvdis_inserted.htm

have you tried rebooting after doing the first parts of my post to see if Autorun / play is now working.

Like this post
bob dob

Likes # 0

Hello again, well i haven't actually restarted because i haven't needed to change anything you see as the value was 1?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Where to buy iPhone 6 and iPhone 6 Plus in the UK: Launch day price, deals and contracts

IDG UK Sites

Is Apple losing confidence in itself?

IDG UK Sites

Professional photo and video techniques for perfect colours

IDG UK Sites

How (and where) to buy an iPhone 6 or iPhone 6 Plus in the UK. Plus: What to do if you pre-ordered...