We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
 
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Linux sound


jon2
Resolved

Likes # 0

I am having trouble with sound, or the lack of it in my Linux OS 2011 system, although I can use skype with no trouble I can't get any sound when I try a video clip from the internet, as I am new to Linux any help would be appreciated.

Like this post
jon2

Likes # 0

Have followed your guide and the outcome is the following:

/etc/modules: kernel modules to load at boot time.

This file should contain the names of kernel modules that are

to be loaded at boot time, one per line. Comments begin with

a `#', and everything on the line after them are ignored.

by the way the q did not seem to work

Like this post
octal

Likes # 0

LastChip

I'm not sure what you are trying to achieve, this is what I get using your commands, much the same as jon2 I should think.

Like this post
LastChip

Likes # 0

OK, a couple of things. "q" will exit you out of cat if the file is too large to see on a single screen and if you use "cat | less" to view the file in pieces. Sorry for the confusion.

The modules file (as it says) should list the modules loaded at the system boot.

I was wondering if the sound module was being loaded and at face value, it isn't. But, then I reconsidered the original post, and note that jon2 can use skype, which doesn't make a whole lot of sense.

There have been issues with sound on PCLinuxOS in the past, and I wrote about them here. However, that was a while ago and I would have hoped that bug has been dealt with.

I can't help thinking there's still something wrong with the configuration, so can I suggest jon2, you have a look through here and see if it's any help. Also please double check kmix and make absolutely sure everything is not muted and turned right up. See here.

Let us know if you still can't get it working and if you can't, please confirm you're using PCLinuxOS 2011.

Like this post
jon2

Likes # 0

I am sorry to be such a pain but I have tried all sorts of tweeks and still no sound, when I use Skype that works fine, but online video or a music disk (CD) nothing, yes I am using PCinuxOS 2011.

Like this post
octal

Likes # 0

Thinking logically about it, if the sound is working on Skype then that seems to indicate the sound is working. As a matter of interest, what media players have you got installed?

By the way, you are not a pain, this is what the forum is for, if it wasn't like people like you asking questions then there wouldn't be a forum, so ask away and don't worry, if we can help you we will.

Like this post
LastChip

Likes # 0

Are you using Skype through the machines speakers or through a headset?

If through a headset, have you tried listening to a CD through that same headset?

I'm trying to establish, whether it's not a software problem at all, but a hardware one.

Like this post
jon2

Likes # 0

I use a headset and use the software that came with Linux for CDs (VLC) although it shows the track playing there is no sound, any online video no sound, Skype works fine

Like this post
dth

Likes # 0

I use kde (with opensuse 11.4) and might be able to help.

On the bottom of the screen to the right you should see an icon for sound (looks a little like shining from a torch). If you left click on this and then select mixer - this takes you to the sound settings. Would suggest that you push all of these to the top (to see if that is the problem).

Like this post
jon2

Likes # 0

Many thanks dth but have tried all of those setting with no results, I have no doubt that it will be something silly but its just finding it.

Like this post
octal

Likes # 0

I'm not sure about this, but if I'm not mistaken PCLOS uses Pulse Audio. If it does then open the sound preferences and click on the hardware tab, you should see the device there, it should say something like Internal Audio, in the drop down menu at the bottom it will probably have Analogue Stereo Duplex as it usually defaults to this, try changing that to Analogue Stereo Output, while you are in that window run a music file and see the the application appears in the Applications tab, in your case it will probably be VLC.

I did have some problems with Pulse Audio some time ago not working on certain applications for some reason, after I had changed things as above then it all worked.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Galaxy Note 4 release date, price and specs 2014

IDG UK Sites

What's the best smartwatch? 11 iWatch rivals compared in our wearables round-up

IDG UK Sites

App cloning: the mobile software industry’s hidden shame

IDG UK Sites

Developers get access to more Sony camera features