We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Printer Installation problem - MP495 USB


dal5band

Likes # 0

My neighbour bought a Canon MP495 multi-printer and it will not install on his Windows XP PC. The PC will not detect the printer.

The printer is deteced and installs correctly on my W/XP PC and on my W/7 laptop - no problem.

Another printer (a Dell) is deteced and installs correctly on my neighbour's PC.

It is only the combination of the MP495 and that PC that will not work. I notice the problem seems to be in the area of seting up a "USB virtual port for printer" which does not happen in this case. It may be to with detecting the printer by the plug and play system. The hardware works fine in all other combinations.

Like this post
johndrew

Likes # 0

Have you gone to 'Control Panel/Printers and Faxes' to see what is already installed? XP should automatically detect the printer when it is attached and switched on. If not you could go to 'Control Panel/Printers and Faxes' and select 'File/Install Printer' and see if that helps.

Failing the above have you tried installing the drivers for the printer from the CD it should have come with?

Like this post
dal5band

Likes # 0

I've done both - used the MP495 install wizard that came with the printer and also used "add printer" via control panel. Both methods fail at the point of plugging in the printer to the USB and switching on - the PC just does not see the printer. Using the same cable and port etc the PC immediately detect a Dell printer.

On the other hand the MP495 installs on another PC. It's something to do with XP or plug & play versions / compatibility etc. I don't have the confidence to go delving into the Windows registry etc.

Like this post
shellship

Likes # 0

Some of these printers are v finicky to install - everything has to be done in exactly the right order. I may be teaching grandmother but have you tried unplugging everything, removing any installed Canon software and then ensuring that you do things in exactly the right order.

Like this post
chub_tor

Likes # 0

This link is a little obscure but it sounds very similar to your problem and a solution is posted.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Galaxy Note 4 release date, price and specs UK: Is this the actual Note 4 - video

IDG UK Sites

How Apple, Adobe, Microsoft and others have let us down over UltraHD and hiDPI screens

IDG UK Sites

How Ford designs next-generation cars at its Melbourne Design Centre

IDG UK Sites

iPhone 6 release date, rumours, video, UK price & images: iPhone launch event confirmed for 9...