We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

What's wrong with my USB 2.0 ports


mike4smg

Likes # 0

I currently have an Acer Aspire M1610 Intel Pentium Dual Core E2140. I'm running Windows Vista Home Premium. Just recently, whenever I plug a USB device into one of my USB 2.0 ports, I get an annoying message telling me that "....this device may work faster if it is plugged into one of the USB 2.0 ports....." and then gives me a list of where they are.....as if I didn't know!!! I have double-checked the specifications of my system, and because I have the multi-card reader on the front of the tower, I just have the 2 USB 2.0 ports instead of 4. However, I've tried all the other USB ports and still get the same message.

Has anyone else had the same problem and perhaps you can point me in the direction of a solution before I go even more grey!!!!!

Many thanks

Mike

Like this post
Sapins

Likes # 0

It's usually a bad connection, Switch off and give the connections a gentle push, I had a problem, seperately, with the usb and card reader and also with a usb hub plugged into the motherboard.

Like this post
cocteau48

Likes # 0

A common way to try and resolve this is to delete all references to USB devices in Device Manager. Subsequently rebooting your machine will reinstall all the items just deleted and,if you are lucky,may resolve the problem. It's certainly worth a try.

I struggled for weeks to resolve this issue myself until I discovered that it was the USB device itself causing the problem. I had a Freecom Ext HD which threw up this message and it was only after I got the opportunity to try it in a different machine,and got the same message,that the penny dropped that it was the Ext HD at fault. As soon as I replaced the Ext HD it resolved the problem.

I have subsequently been through the exact same scenario with my Freecom Ext optical drive with the same result. Both devices still worked and were about two years old when they started to throw up the "could work faster" message.. Would not take a Freecom device as a gift in future.

Like this post
mike4smg

Likes # 0

Many thanks for your initial responses. @cocteau48, when you say delete all references to USB devices in Device Manager, do you actually mean delete or just disable them? just wanna get that clear in my own mind

Like this post
cocteau48

Likes # 0

"do you actually mean delete or just disable them?"

Uninstall everything under USB controllers.

Windows will rebuild them afresh when you reboot.

Like this post
buteman

Likes # 0

Or check device manager and see if any yellow exclamation marks under USB Controllers.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

4G to get faster and cheaper with Freeview spectrum: We're in for a wait though

IDG UK Sites

Apple's 2014: A reflection

IDG UK Sites

Artist creates a geometric rave in a chapel for The House of St Barnabus

IDG UK Sites

Mac mini (Late 2014) 1.4 GHz review: Mac mini is sort of upgradable, but is it any good as it is?