We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

IE 9 Glitch?


Seadog

Likes # 0

HI

I recently upgraded to IE9 and windows 7 service pack 1. I am running Win 7 Professional.

Since doing this I seem to have a glitch or problem when clicking on links on certain web pages. For example if I hover on a photo in Facebook, an http://www. address bar appears at the bottom of the page but when I left click it to open it, nothing happens, similarly on eBay when hovering over say, page 2 while viewing page 1 an address bar appears but when clicking again nothing happens. This is not the same for all web sites, PCA site seems to work ok.

If I right click and select 'open link in new tab' the link will open (but obviously on a new tab) in both the above cases.

Is this a web site issue (they need to update their site programming) or an IE9 glitch, and has anyone else experienced or heard of this?

Like this post
Seadog

Likes # 0

I've just found that if I right click and click on 'open' the link opens as it should if you left click on it..............................

Like this post
rdave13

Likes # 0

Regardless of the settings in IE9 to open in a new tab - it doesn't work, even in compatibility mode. However, if you don't have software drivers installed for your mouse, the registry settings are for the middle-click (wheel) to be the default to open in a new tab. The right click menu also offers this choice though cumbersom.

Like this post
Seadog

Likes # 0

Maybe I should have re-phrased this, normally, simple single left-clicking on a link on a web page(for example the next page in a series of pages) will open it in the same tab, this does not happen now on several web sites.

Why? Have I got some settings wrong or is it the web sites at fault.

The only way I can open these links/go to the next page is either by right clicking and selecting either 'open' or 'open in a new tab'.

The centre mouse button will also open the link in a new tab.

Like this post
kdt

Likes # 0

I had problem of freezing on AOL site but after managing add-on looks alright now.I had uninstalled & reinstalled IE9 and had tried MS Fix It.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Samsung Galaxy Alpha vs iPhone 5S comparison review: Metal smartphones fight

IDG UK Sites

Gateway to your kingdom: why everybody should check and update their broadband router

IDG UK Sites

Fonts review

IDG UK Sites

Best Mac? Complete Apple Mac buyers guide for 2014