We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

USB host controller gone missing


Septogenarian

Likes # 0

For some unknown reason all my USB ports have stopped working and when I look in device manager I find the reference to USB host controller missing, and all my USB devices have a yellow exclamation mark.Have tried scf / scannow as seen in replies to similar problems from other people but negative result. Have looked at websites that supposedly supply free replacement drivers but in the end they ask for payment. Have also tried the "Fix-it" service from Microsoft but seems a waste of time.
Would appreciate suggestions in simple terms. Thanks.

Like this post
ronalddonald

Likes # 0

it may ask have you got disc say yes and see

Like this post
lotvic

Likes # 0

ignore ronalddonald (he also has a documented problem)

Like this post
Fruit Bat /\0/\

Likes # 0

In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

Like this post
Septogenarian

Likes # 0

Thanks for that FB but still get a problem with svchost.exe error code 39 . Also usbehci is suspect.
So.. Iv'e come up with a workaround I'm going to try. Iv'e got out an old hard drive from my junk box and temporarily installed XP on it to see if the usb ports work , and they all do , so suspect the drivers on my everyday PC must be corrupted . So with complete abandon am going to replace them all with drivers that I know work , after all they are the same components on the same PC . Kill or cure !

Like this post
Septogenarian

Likes # 0

Have ditched Windows in favour of Linux Ubuntu 11.04 which although only in beta version is absolutely am - aaaaa - zing ! , and everything "just works". However suggest anyone interested waits for final release . Thanks to all who read and tried to help me with this problem .

Like this post
finerty

Likes # 0

i use linux mint where you get the video player, whereas with ubuntu you have to download it.

if your using firefox i suggest you go on youtube and type speeding up firefox.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

New iPhone 6 review: best ever iPhone is very good... but no longer the best phone you can buy

IDG UK Sites

Is Apple losing confidence in itself?

IDG UK Sites

Professional photo and video techniques for perfect colours

IDG UK Sites

How (and where) to buy an iPhone 6 or iPhone 6 Plus in the UK. Plus: What to do if you pre-ordered...