We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Loose internet connection every couple of hours


grajackgor

Likes # 0

This has been happening for about a 5 days.
Problem cured by rebooting
Tried normal repairs and winsock repairs.
have Windows XP with Service pack 3 Take automatic updates. Desktop computer
Use AOL software and Internet explorer to access internet. Use Speedtouch 585v6 router
Windows diagnostics comes up with Winsock problem which it fixes and advises reboot. But problem is solved by reboot any way. Any body got any ideas?
Windows 7 laptop doesn't seem to have problem, but actually dont use it for that long usually

Like this post
mgmcc

Likes # 0

Go into the router's settings and check that the DHCP Lease Time is set to an adequate value. Mine is set to 1440 minutes (24 hours), although the DHCP server *should* automatically renew the lease long before it expires.

In your case, a short lease time might be causing the PC to lose its IP address. When a PC is rebooted, it will request a new IP address from the DHCP server. Alternatively, you could try giving the PC's network adapter a fixed IP address to see if that resolves the problem.

Like this post
grajackgor

Likes # 0

Thanks mgmmc

I managed to find the DHCpleese time settings. They are set to 24 hours.
As to giving a fixed IP address to the adapter; not really sure how to do this and could it cause other problems?

Like this post
mgmcc

Likes # 0

To allocate a fixed IP address go into the Network Connections folder ("Start > Run", type NCPA.CPL and click OK) then right click the appropriate network connection - Local Area Connection or Wireless Network Connection - and select Properties. Highlight the entry for "Internet Protocol (TCP/IP)" and click the Properties button.

Select the option to "Use the following IP address" and enter addresses such as these:

IP address - 192.168.0.40
Subnet Mask - 255.255.255.0
Default Gateway - 192.168.0.1 (the router's IP address)
DNS Server - 192.168.0.1 (the router's IP address)

NOTE: The first three octets (numbers) of the IP address you use *MUST* be the same as those of the router's IP address. The final octet can be any *UNUSED* number between 1 and 254. I suggested 40 which should avoid any conflicts and be outside the 'pool' of addresses from which the router allocates by DHCP. Check first what your router's IP address is by running IPCONFIG /ALL in a Command Prompt window and looking for the Default Gateway address.

To revert to automatic addressing set *BOTH* IP and DNS sections back to getting their addresses automatically. Using fixed addresses won't cause any problems as long as there isn't a conflict with two devices having the same IP address.

Like this post
grajackgor

Likes # 0

I found that I didn't need to reboot to fix the problem, just log out and log back in. Since I did this the problem seems to have gone away. At least over the weekend.
I will keep the option of fixed IP address, mgmcc, for reserve, in case it happens again. Thanks for your time and suggestions

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Nokia branding killed in place of 'Microsoft Lumia': Windows Phone moves into new era

IDG UK Sites

Why you shouldn't buy the iPad mini 3: No wonder Apple gave it 10 seconds of stage time

IDG UK Sites

Halloween Photoshop tutorials: 13 masterclasses for horrifying art, designs and type

IDG UK Sites

Should you update your iPhone or iPad to iOS 8? iOS 8.1 brings back Camera Roll, adds Apple Pay in...