We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

How do I set up a home network


Chitterlow

Likes # 0

I have a Windows 7 desktop pc LAN wired to my Router and a Vista laptop that connects to the internet via WiFi. How can I set up a network so I can share files?

Like this post
mgmcc

Likes # 0

As both computers are connected to the router, they are already "networked". Make sure both computers are in the *same* Workgroup (the default name for both Vista and Win7 will probably be WORKGROUP anyway).

Ideally, you want to be logged in to both computers with the *same* Username & Password, then set any folders that you want to have available over the network as "shared" by right clicking and selecting the Sharing option.

In the Network and Sharing Center of both computers (in Win7 you need to click the "Change advanced sharing settings" link at the left), make sure you have turned on:

- Network Discovery
- File & Printer Sharing
- Public Folder Sharing

In Win7, also enable "File sharing for devices that use 40 or 56-bit encryption.

See how you get on with that and post back if you have problems.

Like this post
Chitterlow

Likes # 0

Hi MGMCC. Thanks for your response. I have followed your instructions and I am now able to log on to the new network with the laptop. Next when I try to log on with the desktop, I'm asked to input the password. When I do this the computer starts trying to log on but dosen't seem to be able to do so. Do you think that this may be because this computer is only set up for a wired connection at the moment? The computer is capable of connecting by WiFi. How do I enable this?

Chitterlow

Like this post
mgmcc

Likes # 0

Whether you connect by ethernet cable or "wirelessly" doesn't make any difference. The password you're being prompted for is that of the *remote* computer that you are accessing over the network although, as I suggested previously, it is ideal if both computers have the same Username and Password.

Like this post
Strawballs

Likes # 0

Win 7 uses a password by default for networks but only works in 7 so as you are using Vista as well you will have to go into the shareing centre on the win 7 machine and turn off the password facility

Like this post
Chitterlow

Likes # 0

Hi Guys. Still no joy. Let me explain what I have done so far. On my Vista laptop I created a new network which I called "Colin's Network" and gave it a password. Next I log on to this network and I see a message saying that it is waiting for other computers to join the network. Next, on the Windows 7 desktop, I right click on the connection symbol at the bottom of the screen. A small window opens and I can see "Colin's network" along with my usual Internet connection. I opt to log on to Colin's network and I am asked to input the "Network security key" (not the remote computer password). On doing this the computer connects to this network. It then atempts to "Identify" the "Unknown public network" which it apparently fails to do and then disconnects and reconnects automatically to my usual internet connection. I have dissabled the password option on bothe computers as advised.

Like this post
mgmcc

Likes # 0

I don't understand what you mean by "created a new network". If both computers are in the *same* Workgroup and connected to the router successfully for their internet access, then they are already suitably networked. You shouldn't have set up anything additionally. The "Connection" symbol in the area beside the clock is for connecting to an available internet connection, but you already have this via your router.

Make sure that any folders that you want to have available over the network are "shared" with suitable permissions set. Set Password Protected Sharing to "Off". If you're using third-party firewall software, such as Zone Alarm, it should be configured to allow access to the networked computers, which may involve adding their IP addresses in a "trusted" section.

Like this post
Chitterlow

Likes # 0

Making progress at last thanks to you. The problem was that the computers were not in the same workgroup. The W7 desktop is now set to "Home" and the Vista Laptop is set to "Private" (There isn't a "Home" option). I can now access files remotely but only those in the "User">"Public" Folders. I would like to be able to access "My Documents" remotely but I can't see any settings options which will enable me to do so. Can you advise?

Like this post
mgmcc

Likes # 0

In the Windows 7 PC, right click "Documents", select "Share with" and then Specific People. If you're logged in to Vista with the same Username, it should already be shown and you just click the Share button. Otherwise, add the name with which you're logged in to Vista, then click Share.

The procedure should be basically the same in Vista. The right click option is "Share" rather than "Share with".

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

OnePlus Two release date rumours: Something's happening on 22 July

IDG UK Sites

13in MacBook Air review, Apple's MacBook Air 2014 reviewed

IDG UK Sites

5 reasons to buy an electric car and 5 reasons not to

IDG UK Sites

Evernote Skitch: the best way for creatives to doodle feedback