We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

connected wirelessly - but no internet access !!!!


Pepperdog007

Likes # 0

Hi I'm pulling my hair out and going round in circles (and talktalk support no good!)

Problem - My Acer netbook is able to connect to the wireless router but I cannot access the internet.
Other Laptops in the house all connect wirelessly OK.
I'm on Windows XP home edition.
I can connect by cable ok and all works.
This netbook connects wirelessly ok when we were on BT Broadband, and if we use it out and about in cafes etc.

If I look at the Wireless Network connection Status it advise connected, all looks ok but the Activity section shows minimal packets received, although number of sent packets is slowly increasing.

I've got the CMD screen up and typed IPCONFIG/ALL
it matches the same as per my working laptop.
e.g.
DNS Suffix - dlink.com
IP address 192.168.1.5 (end 1.4 for working pc)
DNS Server 192.168.1.1

I get a successful 4 reply if I ping 192.168.1.5 but not if I ping 192.168.1.1 or click here (which on tehe working PC both work ok)

The set up seems teh same across both laptops, although using different wireless adapters (Atheros AR5007EG for teh netbook and Intel R> Pro/ Wireless 2915AGB for teh working laptop)

I've looked at several forums (and although not technical) have tried a few things:

Occasionally I get the notification "limited or no connectivity wireless" but by using the "repair" option on the 'Support' tab in "Wireless Network Connection Propeties" of XP it resolves - or even disconnect/connect.

Talk Talk got me to try changing channel and password of the wireless connection.

I have tried manually set the IP address & DNS Gateway to 192.168.1.1 via "Wireless Network Connection Propeties" - "Internet protocol (TCI/IP) Properties" - using the "general" tab sheet.



I tried IPCONFIG/ RELEASE which set allIP to zero but the IPCONFIG/RENEW failed and I had to repair using "repair" option on the 'Support' tab or wait til it redoes the connection itself.

all suggestions welcome
Pete

Like this post
mgmcc

Likes # 0

I'd suggest as a starting point that you temporarily disable any wireless encryption (WEP/WPA/WPA2) in the router's settings and see if the Netbook then accesses the internet.

Having said that, your inability to run IPCONFIG /RENEW successfully suggests there may be a different issue, as the Netbook appears to be getting its IP and other addresses by DHCP initially.

Like this post
Pepperdog007

Likes # 0

Thanks for the reply mgmcc.

Tried a couple of things
Someone suggested amending my F_Secure firewall to specifically allow the Wireless internet adapter the netbook uses. Atheros AR5007EG. No sucess.

Tried your suggestion - set security to none. Says successfully connected to unsecured network (even rebooted router and netbook). Still the same issues
Recieved packets = 0.
I noted that the IP address is 169.254.244.183 - so tried "repair" option but didn't change it.
Also still fails to Ipconfig/renew. message reads "An error occurred while renewing interface wireless connection: unable to contact your DHCP server. request timed out. No operation can be performed while the Local Area connection has its media disconnected"
Meanwhile the Windows XP automatically reconnects the wireless communication part

What's next?

Like this post
mgmcc

Likes # 0

Originally the Netbook was able to get a correct IP address, but is now getting only a "169.254" address. After disabling the router's security, did you also delete the existing wireless 'profile' in the Netbook before trying to connect again?

Like this post
Pepperdog007

Likes # 0

Well it's been a battle and I'm not sure which bit has resolve the issue.
I put the notebook into safemode boot up(using command MSCONFIG adn amending Boot.ini tab. Deleted any reference to the wireless connection.
Set my Firewall to accept the Network wireless adapter.
reset DHCP with command "NETSH INT IP RESET LOG.TXT"
reset network "NETSH WINSOCK RESET CATALOG"
Using the other laptop and network cable reset the Wireless link on router, changing its name, lowering the encryption to WEP and a new password.

Rebooted everything router, laptops etc
After all that it now works!

Many thanks for your help and suggestions
I pray it never throws its toys out the pram.
pete

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Nokia Lumia 930 review: The flagship Windows Phone 8.1 smartphone

IDG UK Sites

Live Blog: Apple financial results, record June quarter, 35.2m iPhones sold, $37.4b revenue

IDG UK Sites

Welcome to the upgrade cycle - you'll never leave

IDG UK Sites

Why smartphone screens are getting bigger