We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Lacie Extreme 1TB hard drive problem


ccuk

Likes # 0

I have a Lacie 1TB Extreme hard drive.

I have just purchased a new PC with Vista Business 32 bit operating system, I disconnected the drive set up the machine, re connected the drive and all should be well! But not so.

At first I thought it was a Vista problem but anow notice the mains supply is buzzing badly and affecting the start up of the drive.

First I think I need a new mains adaptor/power supplier. Maybe the problem is Vista also?

Has anyone experienced similar?

Does anyone know where I can purchase a new mains adaptor?

Thank you

Sandra

Like this post
wee eddie

Likes # 0

Why not start a fresh thread?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Where to buy iPhone 6 and iPhone 6 Plus in the UK: Launch day price, deals and contracts

IDG UK Sites

Is Apple losing confidence in itself?

IDG UK Sites

Professional photo and video techniques for perfect colours

IDG UK Sites

How (and where) to buy an iPhone 6 or iPhone 6 Plus in the UK. Plus: What to do if you pre-ordered...