We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Configuring a Wireless Repeater


seanquinn

Likes # 0

My wirless signal is very low in the living room so I bought an Access Point (Edimax from Dabs) that can be configured as a Wireless Repeater. I have mounted the repeater in the kitchen which is half-way between the living room and the Modem/Router. Signal strength from the repeater is now very good.

I have set the SSID of repeater and wireless router to be the same and the wireless network now shows up as only one AP. So far I have been unable to connect to the Internet using the repeater, however. If I switch the repeater off and get into a position where the original router signal is OK I can connect to the Internet OK. When I switch the repeater on, it takes over the wireless connection (becaue it is stronger) and I loose the Internet. So the repeater apparently isn't connecting to the router?

I suspect there are issues surrounding DHCP...it is currently enabled on both repeater and modem/router and my laptop is configured to receive an address automatically. Otherwise what am I doing wrong?

By the way the Edimax manual was very little help...poor English and a lot of knowledge assumed. Help anyone?

Like this post
Ashrich

Likes # 0

Turn off MAC filtering on the router , as repeaters connect to routers via MAC addresses the router may be blocking it , just a thought ....

Ashley

Like this post
Ashrich

Likes # 0

And another thought ( I wish we could edit posts after posting ...) might they both have the same IP address , therefore confusing things ?

Ashley

Like this post
seanquinn

Likes # 0

Sorry I did not mention that I have not enabled encryption on this network yet. I have however left the Router Firewall on, so will try disabling that.
If DCHP has to be left off totally, I can set IP and DNS settings for all my own computers, but it would be niceto have it on auto for visitors (I have two grown children who often visit and have their own laptops.
Currently I have the router manually set as 198.162.2.1 and the repeater as 192.168.2.2.
When the router is allocating IPs I have set the range to be allocated as 192.168.2.3 to 192.168.2.100. Also I have set the Subnet for all systems as 255.255.255.0.
It should work, shouldn't it? My only worry is that both router and repeater are cheapo itmes and the router had no facility to enable it for WDS.
What do you think about the issue of setting them both to operate on the same channel?

Like this post
LastChip

Likes # 0

First, in principal, I can't see anything wrong with the addresses you're using. At face value, there is no good reason why DCHP shouldn't work. However, is 192.162.2.1 a typo? Should you have written 192.168.2.1?

It seems that whether you set them to the same channel (or not) depends upon:

a: whether they can facilitate WDS

b: what sort of network you are setting up.

To date, everything I've read about multi-point wireless access says use different channels, as each may interfere with the other. However, both the manufacturer of your access point and click here say use the same channel for a WDS.

The link is worth reading, as it clearly says not all components will support WDS and data transfer is via MAC addresses rather than the traditional IP address.

Perhaps it will simply turn out, your router is not capable of providing WDS.

Like this post
seanquinn

Likes # 0

Thanks LastChip. The Wikipedai article was very good.

However....
Found this in the Router manual:
"A group of wireless stations (computers) and a single Access Point using the same SSID form a Basic Service Set (BSS). Using the same SSID is essential. Devices with different SSIDs are unable to communicate with each other.

A group of wireless stations and MULTIPLE ACCESS POINTS all using the same SSID form an Extended Service Set (ESS). Different access points can use different channels. In fact to reduce interference, it is recommended that adjacent wireless points SHOULD use different channels."

The Repeater manual says this:
"ESSID - make sure that the ESSID of all stations in the same WLAN network are the same. You should assign ESSID in........Universal Repeater Mode" (the one I am using).

Further down it says, "Root AP SSID - in Universal Repeater Mode ....you should assign the SSID of the Root Access Point" (there's a box for it on the SetUP screen......it doesn't elaborate as to whether Root and Repeater should share the same SSID, but since they are part of the ESS, I presume they should (why then have a separate box for it as the ESSID is set in another box on the same screen?)

"Channel Number - select the appropriate (?) channel to correspond with your network settings." (IMPLIES it should be the same as the channel of the router which is the source Access Point, but is that what it means? The Router manual states "If using multiple Access Points, adjacent Access Points SHOULD USE DIFFERENT Channels to reduce interference."

Tried again with router and repeater set to the same SSID but different Channels (6 and 11), with the only DCHP server on the the router and the Router firewall off (although I can't see why that should matter since it only blocks traffic between the LAN and the WAN (Internet) and shouldn't interfere with communication within the local network...nevertheless my test of the success of the repeater up to now was to see if I could access the Internet from the Laptop through the repeater...so left the Firewall off and this time tried to see my other 'Workgroup Computer' and its printer (which I can see working to the wireless router direct) but still no joy. It appears that the repeater is not repeating the router's signal as I don't get an IP address for the laptop either and have to set it manually.

Can't think of anything else to try. It must be a hardware incompatibility. The Router had no setting for WDS and Wikipedia says anyway "WDS may be incompatible between different products - even sometimes from the same vendor.

Like this post
Fernwood

Likes # 0

Hi, My understanding is that you will require 2 AP's to set up a repeater as one of them needs to be connected to your router using a cable. I have 2xNetgear WG602's and that is the only way I can use a repeater.

So it's set up as follows:-

router--cable--AP---wireless---AP---wireless---PC

Like this post
Fernwood

Likes # 0

Forgot to mention that to prevent buying a second AP, you could cable the AP you already have to your router and use it as a wireless AP rather than a repeater but I'm assuming you don't want to run a cable that far?

Like this post
seanquinn

Likes # 0

Hi Fernwood and thanks for your suggestion. I hear Netgear is the best kit around, but my stuff is somewhat "cheapo"....KeyCorp router and Edimax AP. I don't need another AP because the router is also a wireless AP..it's actually a Wireless ADSL modem/router and connected to my main PC by Ethernet cable. It works a treat most places in the house but the front lounge is a bit far away and the connection sometimes drops with my laptop. I have alreay fitted a directional high gain antenna to the router but little improvement. I thought a repeater might be a better solution, but no success yet.

Like this post
seanquinn

Likes # 0

I shouldhave posted this a while back, but I eventually got extra instructions from Edimax who make the AP, and it is necessary to configure the AP to be on the SAME CHANNEL as the wireless router, with a DIFFERENT SSID, and DHCP is set TO ON and allocated by the router (in my case within a range I defined (198.162.2.1-198.162.2.10) - or it can be left open.

Now works a treat !

Like this post
StefaniaCastelli

Likes # 0

Surely the dude that started this thread will have solved his issue.
Fot the googlers in search of a solution, I can say that after hours of trials, the only way I found to make a repeater do its job is to select a different broadcasting channel in the repeater setting and hide the broadcasting of the SSID.

This way, everything works smoothly.

Even WPA-PSK encrypted signal is repeated with no problem.

The only thing you must remeber is to store the Wireless Network information in the PCs involved.

I mean that if you are too far from the router AP, being the SSID hidden in the repeater, you won't access the network.

So, the first time you access the network, do it through the main router, then store the information and you'll be able the next times to access directly from the repeater....

That's it.

Of course all the other setting cited in the previous post are correct (same SSID, correct DHCP setting on the main router etc...)

Stefani Castelli

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Best Christmas 2014 UK tech deals, Boxing Day 2014 UK tech deals & January sales 2015 UK tech...

IDG UK Sites

Chromebooks: ready for the prime time (but not for everybody)

IDG UK Sites

Hands-on with Sony's latest smartglasses

IDG UK Sites

The 13 most inspirational Tim Cook quotes