We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Configuring a Wireless Repeater


seanquinn

Likes # 0

My wirless signal is very low in the living room so I bought an Access Point (Edimax from Dabs) that can be configured as a Wireless Repeater. I have mounted the repeater in the kitchen which is half-way between the living room and the Modem/Router. Signal strength from the repeater is now very good.

I have set the SSID of repeater and wireless router to be the same and the wireless network now shows up as only one AP. So far I have been unable to connect to the Internet using the repeater, however. If I switch the repeater off and get into a position where the original router signal is OK I can connect to the Internet OK. When I switch the repeater on, it takes over the wireless connection (becaue it is stronger) and I loose the Internet. So the repeater apparently isn't connecting to the router?

I suspect there are issues surrounding DHCP...it is currently enabled on both repeater and modem/router and my laptop is configured to receive an address automatically. Otherwise what am I doing wrong?

By the way the Edimax manual was very little help...poor English and a lot of knowledge assumed. Help anyone?

Like this post
Ashrich

Likes # 0

Try disabling it on the repeater , there may be confusion between the two of them , I have to disable it on my Trendnet wireless router as my satellite modem/router gives out DHCP as well .

Ashley

Like this post
Ashrich

Likes # 0

Try disabling DHCP , that is .....

Ashley

Like this post
seanquinn

Likes # 0

Thanks Ashley
I tried disabling DHCP on the repeater (satellite) and then I couldn't connect to it without manaully setting an IP address for my laptop. I thought my modem/router would deliver an IP address through the repeater, but obviously not.

Didn't set a DNS on the laptop though, which is probably why I could raise any web sites. I will try using DHCP only on the repeater instead and see how we get on.

There must be some way I can test if the repeater is talking to the router?

Like this post
LastChip

Likes # 0

Are you trying to use the same channels?

Like this post
Ashrich

Likes # 0

What type of encryption are you using , routers using a repeater via WDS can only use WEP not WPA , and the two items connect via MAC addresses rather than IP assignments . So each one must have each others MAC address in the MAC filter section of the router/access point set up . SSID's can be different as long as the can communicate by MAC . What make is the other Wireless router ? Does it support WDS ( wireless distribution system ) if it does it may need to be switched on in the set up pages of the router .

Ashley

Like this post
seanquinn

Likes # 0

LastChip: I am using the same channel on the wirless router and the repeater. This was recommended in the user manual for the repeater, which is an Edimax EW-7206APG wireless access point which has an option for configuring it as a repeater.

The router (A Kcorp KLS5810 is configured as a NAT router + modem (which worked OK so far in that mode) and I have now turned DHCP off on the router and on on the repeater as Asrich suggested....I don't see any option for setting router to WDS as such, so don't know if that means it won't. I thought it just accepted the repeater as a wireless client..as least that's what the repeater manual suggests..they are supposed to talk to each other as if the repeater was a PC client.

Still testing......:-(

Like this post
LastChip

Likes # 0

Try using different channels on the router and access point.

Channels 1, 6, and 11 are recognised as giving sufficient separation.

It depends a lot upon how your access point behaves. Some auto-configure for the best reception; some don't. It's a bit of a "black art"!

click here for some more information.

Like this post
Ashrich

Likes # 0

Have you tried disabling any encryption ? As I said before , a wireless repeater can only use WEP ....

Ashley

Like this post
seanquinn

Likes # 0

Thanks Asritch and LastChip for staying with me on this........
So far I have tried:
Using different SSIDs and same SSID
Using different channels and same channel
(All permutations of above)
Using DHCP on repeater only
Using DHCP on modem/router only
Using DHCP on both

When they are both on the same channel, I can connect to the repeater only (this is about 30ft and three walls away from the router and only the repeater shows up as an available wireless point). I cannot however access the Internet.

If I select different channels, I can choose to connect instead to the router, which is weaker signal but usable, and I can then connect to the Internet.
So the problem is communication between the repeater and the router...maybe because they are different makes they may never work together (I read that in another forum) though you would think modern technology would have overcome such compatability issues !

Like this post
LastChip

Likes # 0

In principal, you should only have one DHCP server. If you have more than one, the clients may become confused about which address to accept.

If you are going to use DHCP, it would be normal practice to use the router as the DHCP server. There are good technical reasons for doing this.

While we are on this subject, if you choose to use the router for DHCP, make sure neither of your computers are configured to act as a DHCP server as well. This would cause the same problems as having both the access point and router providing addresses.

Or, you can turn it all off and configure manual addresses.

As much as it may seem a wild thing to do, until you get this configured correctly, you should turn off any encryption (as Ashrich has already suggested) and ALL firewalls. (Don't forget the built in firewall in XP). By far the single biggest cause of failure in any network set-up are firewalls and they should only be reintroduced one at a time, once you have a reliable connection.

Once you have succeeded, turn on the router firewall first (as this is the point of entry for the whole system) and make sure you still have a reliable connection. Then introduce any software firewalls you may wish to use - one at a time and test after each introduction.

There are sometimes compatibility issues with different makes of equipment, but not always.

Are you certain, that all devices are using the same range of addresses; for example 192.168.x.x or perhaps 10.x.x.x ?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

45 Best Android games: top Android games for your smartphone or tablet in 2014 (24 are free!)

IDG UK Sites

How Apple, Adobe, Microsoft and others have let us down over UltraHD and hiDPI screens

IDG UK Sites

Do you have the X-Factor too? Mix Off app puts fans in the frame

IDG UK Sites

iPad Pro release date, rumours and leaked images - 12.9 screen 'coming in 2015'