We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Connected to Wi-fi router but not Internet


Springheeledjack

Likes # 0

I have one laptop running WinXP home connected by Belkin PCMCIA Wi-fi card to NTL thro' a Wi-fi Belkin router - no problems.
I also have a desktop running WinXP Pro which has 'limited or no connectivity' although it has an excellent wi-fi connection to the router, there is no connection to the internet.
The IP of the router is 192.168.2.1 and the laptop is 192.168.2.2.
The desktop IP is 169.254.169.230 which I think has been allocated by windows?
How can I get it on to the internet?

Also, I have an older laptop running ME with similar probs tho' if I wire it to the router with a patch lead I can get on the internet.

Like this post
mgmcc

Likes # 0

In the XP desktop PC which has a "169.254" address, open the Network Connections folder, right click the Wireless Network Connection and select "Repair". This will force a renewal of the IP address and, if it can access the router, it should get an address in the 192.168.2.x range.

For Windows ME, open a Command Prompt window and run the command "IPCONFIG /RELEASE_ALL" which should release the existing addresses and set them to 0.0.0.0 and then run "IPCONFIG /RENEW_ALL" to renew them. Those are actually Windows 98 commands because I don't have ME installed. If they produce an error, run "IPCONFIG /?" to get a list of valid IPCONFIG commands.

Have you actually "Connected" to the wireless network with these two adapters? In other words, have you run the wireless adapter's software, scanned for "Available Wireless Networks", found and highlighted the one that matches your router's SSID (network name) and selected the option to "Connect" to it? Once "connected", the little icon will get its "halo" to indicate it is connected to that network and it should then get its correct IP address by DHCP from the router. Any WEP or WPA encryption key will need to be entered when "connecting".

Like this post
Taff™

Likes # 0

Go to Network Connections and right click the wireless connection then select Properties. On the general tab highlight with one click, the TCP/IP and then Properties again. Make sure that both the "Select automatically .." settings are selected.

Reboot the computer and Post back.

Like this post
Taff™

Likes # 0

Morning mgmcc!

Springheeledjack - After you`ve done all mgmcc`s as well of course?

Like this post
Springheeledjack

Likes # 0

On the XP desktop PC I did as you said, "Repair".
It said it was disabling the device whilst renewing the IP address but then after a while I got the following message: "Windows could not finish repairing the problem ecause the following action could not be completed - Renewing your IP address".

On the ME laptop, releasing and renewing the IP doesn't seem to do much. The IP comes back slightly different at 169.254.127.7, the subnet mask is 255.255.0.0 (whereas the XP laptop which is ok has 255.255.255.0), There is nothing for the default gateway, the DHCP server is 255.255.255.255 (the other laptop is 192.168.2.1).

I have setup the software correctly, I am actually connected to the router but not the internet.

Like this post
sitem

Likes # 0

I've recently set up BT and Cable wireless networks for friends, both of which have had the same problem. The fix for both of them was nothing more than reseting the router. Hope it helps.

Like this post
Springheeledjack

Likes # 0

I restarted the router but to no avail. On the Belkin settings webpage I downloaded a firmware update for the router. Once this had installed and restarted the router the desktop PC is now connected !
The ME laptop is still not sorted but I can live with that for the time being.

Thank you all for your help.

Like this post
Sammyrai

Likes # 0

Hello there, I'm new to all this, and to computers really. I've been having the exact same problem on my laptop and I researched all over the net, and spent hours on the phone with my ISP trying to sort this out but no luck. I finally managed to sort it out so I thought that I should post somewhere so that I could help anyone who googles the same sort of problem.

If you can connect to your router via wireless but cannot connect to the internet or get limited or no connectivity then this should help you. This also resolves problems if your IP Address is 168. something or you have no IP.

What you need to do is log into the router you have from IE, usually 192.168.0.1 username is usually username and password is password or whatever you've been given. Find the routers wireless settings and change the setting to WEP, or disable it if you feel the need to. Set the WEP Security Encryption below to whatever and right down the WEP key that is generated.
Save what you've done and signout.

Now on your laptop you should be disconnected from your router, if not do so manually. Reconnect and type in the WEP when prompted. Your connection will then increase and after a while you will get internet connection. This may take a minute or so, just be patient.

That should be it, I hope this helps anyone with this problem because I had such a hard time trying to work out what was wrong.

Thanks.

Like this post
postie24

Likes # 0

Wep encryption is easily broken,change it to wpa,its far more secure.
Choose a random wpa key from here
click here
And go through the same procedure as Sammyrai says above to enter new key.

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

The 30 best TV shows on Netflix UK: Our pick of the best programmes you can watch right now

IDG UK Sites

Nostalgia time: Top 10 best selling mobile phones in history

IDG UK Sites

VFX Emmy: Game of Thrones work garners gong for Rodeo FX

IDG UK Sites

Apple 13-inch MacBook Pro with Retina review (2.6GHz, 128GB, mid-2014)