We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message
Contact Forum Editor

Send an email to our Forum Editor:


PLEASE NOTE: Your name is used only to let the Forum Editor know who sent the message. Both your name and email address will not be used for any other purpose.

Tech Helproom


It's free to register, to post a question or to start / join a discussion


 

Avast update causing XP boot problems?


wester john

Likes # 0

Last night I noticed a new Avast update had been installed. Today when i tried to boot up my PC, Windows XP started loading but never got as far as the welcome page. I tried several times, even looked at safe mode but couldn't find anything amiss. I tried going back to an earlier restore point but that didn't work either.
Could it be the Avast update that is causing the problem and if so what should I do about it? Any suggestions please?

Like this post
Fruit Bat /\0/\

Likes # 0

In safe mode try
Repair XP by replacing corrupt files
Type

sfc /scannow

in the run box, press enter and let system file checker find and replace missing / corrupt file in windows and explorer.This will take awhile to complete and you may be asked for the CD to be in the drive if windows is not preinstalled on the hard drive.

sfc /scannow problems
click here

If that doesn't work then it may be a corrupt driver causing the problem.

Again in safe mode disable the drivers one t a time untill it will boot normally then update / reinstall the offending driver.

Like this post
wester john

Likes # 0

Thanks for these suggestions. Unfortunately when I try scannow I get a message: Windows cannot find 'sfc/scannow'.

Like this post
oldbeefer2

Likes # 0

WJ - note the space after 'sfc'

Like this post
wester john

Likes # 0

I've tried unsuccessfully to use sfc /scannow. I also tried to disable some of the driv
Should I try to repair windows with my CD do you think?

Like this post
hiwatt

Likes # 0

Incase it is the avast update that's caused it why don't you try uninstalling avast.See how it goes then reinstall it?

Like this post
charliechaplin

Likes # 0

Hi there!

YES, I had the EXACT same problem with Avast when it performed this update a couple of days ago (23rd or 24th Nov 2008) and I can confirm that Avast IS the problem. The only solution I have used successfully is to simply remove Avast, as follows:-

1) Restart your computer (press the RESET button or turn off and back on)

2) Keep pressing the "F8" key before Windows starts to load until the boot menu appears (white text on black screen)

3) Select "Safe Mode" (usually the first or second menu option) and allow Windows to load; make sure you log-in using the main "Administrator" logon icon, if this option is available.

4) From the main Windows desktop, click on the "Start Menu" and select Control Panel (or Settings-->Control Panel on some versions)

5) From the Control Panel select "Add or Remove Programs" and wait for the program list to appear.

6) Scroll down to "Avast" and select "Remove".

7) Now select "Uninstall"

8) Reboot your PC when prompted.

Your PC should now boot into Windows normally.

Don't bother to reinstall Avast just yet, as I've already tried downloading the latest version and the same thing happened again... it installed just fine but as soon as I went online, Avast performed the same 'software update' once more and sure enough when I restarted the PC I found it wouldn't boot, just as before, so I had to uninstall it a second time using Safe Mode as before and all is ok now, except I have no virus scanner of course!

You could either wait a week to see if Avast provides a fix for this problem or perhaps try AVG antivirus instead; I didn't much like AVG myself but User Reviews have rated it "4 out of 5" stars on Download.com which is fairly good, as opposed to "4.5 out of 5" for Avast; I much preferred Avast myself (when it WORKED!)

I expected to find LOADS of people complaining about this problem with the latest Avast software update but I'm amazed not to have found hardly ANY mention of it?? Or perhaps it's because all those furious Avast users still can't boot into Windows and therefore cannot register their complaint online?!!

Hope this helps,
Cheers! Charlie

PS. Please let me know if you get Avast working and how you did it, Thanks!

Like this post
lofty29

Likes # 0

Did this programme update this morning, touchwood no prblems yet!!!, the only thing different was that I did NOT restart the pc then,only just now,as I was doing something else at he time. Just hope that it stays OK, I wish companies would work on the basis "if its not broke don't fix it", had CA paid for several years ago, worked fine then they updated the programme, took me days to get rid of it and get the pc working again, same with AVG, hope I do not have to go looking yet again.

Like this post
Nant

Likes # 0

I don't recognise these problems described with Avast.

I have WinXP SP3 fully updated and Outpost Pro firewall.

I manually updated Avast a few days and it has automatically updated daily since - no problems at all. Am I just lucky?

Like this post
Fruit Bat /\0/\

Likes # 0

The Avast update has cause some driver files to be deleted.

This only affects PCs with the relevant motherboard /chipset.

I thought Avast had fixed this problem by now.

Like this post
hiwatt

Likes # 0

First avg now avast.What's going on?

Like this post

Reply to this topic

This thread has been locked.



IDG UK Sites

Where to buy iPhone 6 and iPhone 6 Plus in the UK: Launch day price, deals and contracts

IDG UK Sites

Is Apple losing confidence in itself?

IDG UK Sites

Professional photo and video techniques for perfect colours

IDG UK Sites

How (and where) to buy an iPhone 6 or iPhone 6 Plus in the UK. Plus: What to do if you pre-ordered...