Windows 7 repair

  Silverworm 11 Feb 12
Locked

I have a Dell Studio 1558 laptop with Windows 7 Home Premium. Yesterday, I tried to turn it on but it wouldn't boot up properly so I held down the power button to turn it off to try again. It did this a few times, until it gave me a black screen and an error: An error occurred while attempting to read the boot configuration data. The night before it was working fine and I had shut it down properly.

I have tried using someone else's laptop to make a system repair disc but it would just give me an error. I don't have my OS discs with me right now, and I'm not even sure Dell shipped them with the laptop. So I then tried making a Windows 7 bootable USB by downloading an ISO of Windows 7 and putting it on a USB. I was able to get to the stage where I click 'repair', but then when I have to choose my operating system, there is nothing showing. It told me load drivers for my hard drive, so I downloaded the driver from the Dell website and put them on an external hard drive. However, I tried every 'system information' file and none of them would make my hard drive show up. The weird thing is, when I'm locating the driver to load, all of my drives are showing and I was able to move some important files to the external HDD. The C drive, my normal drive, was renamed D drive though and its name was changed to OS.

I am trying to get hold of any recovery discs or anything that Dell shipped with my laptop, but apart from that, I don't know what to do. Am I going to have to do a clean install?

Thanks in advance for your help.

  difarn 11 Feb 12

Have a look at this article, particularly the solution posted by Gregrocker about making windows 7 active when attempting a repair.

  Silverworm 13 Feb 12

OK I seem to have to made it 10 times worse now by rebooting too many times. I think the hard drive is badly corrupted, my partitions only appear very occasionally now I click on 'load drivers'. Most of the time it just shows an X drive called BOOT.

I managed to get hold of my Windows 7 reinstallation disk that came with from Dell with the laptop. In the rare occasions that it recognises my hard drive, it shows a drive called (recovered) which is the main partition. I tried to reinstall Windows on this drive, but it just gives me an error. I also get a error message every time it searches for drives saying BOOTSTAT.DAT is corrupt. I tried formatting C in command prompt but it just stays at 0%.

I also used Ubuntu live CD, but that didn't recognise any hard drive either.

I've ran out of ideas now, someone please help!

  KRONOS the First 14 Feb 12

Some help here, Bootdat.

Advertisement

This thread is now locked and can not be replied to.

OnePlus 2 UK release date, price, specification rumours: When is the OnePlus 2 coming out? July…

We are being sold the ability to spend money we don't have. And we love it

HTC's head designer on what's exciting in designing for mobile right now

Apple Music preview: Why Spotify should be scared of Apple's impressive new music-streaming service

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message