Windows 7 Clock

  AustinCann 19 Nov 11
Locked

I have windows 7 professional service pack 1 installed on my computer. I found that the clock time does not set to new time even if I change it, after a minute or to it automatically reverts back to false settings. I tried changing it by clicking the clock time on the right bottom corner and changed it to current time. In internet time tab of change time and date setting window, it is set to time.windows.com. Is there anything I could do to set it right? What is the reason of this behaviour?

Kind Regards

  sharpamat 19 Nov 11

Have you synchronized your computer clock with an Internet time serve.

  lotvic 19 Nov 11

Check all settings in Clock time zone you may be set to synchronize time with the wrong Country.

howto set Clock also check Region and Language settings ClickHere

  Forum Editor 19 Nov 11

"it automatically reverts back to false settings"

That's almost certainly because the clock is set to synchronise with the wrong time zone, as lotvic suggests.

  AustinCann 19 Nov 11

Yes my pc is set to sync with internet. I confirm that the time settings is set to UTC Dublin, Edinburgh, Lisbon, London and that all the settings in Regional and Languagues are correct.I wonder if that's got to do something with the hardware?

  lotvic 19 Nov 11

Try putting a new CMOS battery in the motherboard. That's only thing left that I know of that would cause wrong time on clock. (unless you are forgetting to click 'Apply/OK' after you change settings)

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

See 24 hours in London in 1 minute with Paul Richardson's hyperlapse film

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message