Windows 7 advice for boosting Ram

  bpzoom 08 Jan 12
Locked
Answered

The flyer that came with this month's PCA included a tip to utilise a blank USB flash drive for virtual memory. When I go to Properties/ReadyBoost on the USB drive, it says "This device cannot be used by ReadyBoost" Then it says "ReadyBoost is not enabled because the service responsible for ReadyBoost (Sysmain) has been turned off on this computer. An administrator can turn the Sysmain service back on" When I searched, including Microsoft website, there is no recognition of the term Sysmain. Can anyone please advise. Windows 7 64 bit Dell PC

  chub_tor 08 Jan 12

Microsoft Answers Click Here

  difarn 08 Jan 12

This can happen if tweaks have been made to change the start-up procedure.

Very similar to the advice in the above article but may be simpler to follow:-

click on Start and type in services Right-click the Services item with the cog/gear icon next to it and run as administrator.

Scroll down to Superfetch. Right-click > properties > Startup type: Automatic > Apply > OK

Go back to the command prompt and type net start sysmain. The service should start successfully.

  bpzoom 08 Jan 12

Thank you both. Unfortunately, following your paths both solutions, the startup type is already switched to automatic. For some reason the sysmain system will not operate.

  difarn 08 Jan 12

Did you try a registry "fix" - see article attached.

I am wondering if you have missing or damaged system files? Have a look at this article in respect of ready boost.

  bpzoom 08 Jan 12

I have gone through the two routes sfc /scannow, nothing found, and I have edited the registry to give permission over Sysmain to owner user. I already have it as administrator, no effect, it still will not work. I have changed the flash drive for another, same result.

  difarn 08 Jan 12

When you tried to enable superfetch did you see anywhere where you could "Turn off the option "Tune Windows for speed" in the "Optimization" to enable superfetch"

  difarn 08 Jan 12
Answer

Just come across this in a very large blog:-

"I have had the same problem with ready boost. I copied everything in the C:\Windows\Prefetch folder into a new folder on my desktop, then deleted everything in the C:\Windows\Prefetch folder. rebooted and Ready boost is now working on my machine."

  bpzoom 08 Jan 12

difarn, Brilliant, thank you! That blog advice worked a treat. I have no idea why but there it is working on the flash drive. Thanks again and to the others who have replied.

  difarn 09 Jan 12

Excellent news - glad to have been able to help - have learned something along the way too.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message