Windows 10 update not working

  Petesilver 14:18 17 Feb 16
Locked

can anyone help as something seems to have happened to the auto windows Update when I run the fixit app I get the message " Service Registration is missing or corrupt" I have tried a couple of fixes from the internet but have had no luck. Thanks Peter

  Govan1x 15:39 17 Feb 16

Try Control Panel. troubleshooting.Fix problems with Windows updates.

Or go to services and make sure Windows Update is running and set to automatic. While in there do the exact same with Windows Firewall.

  Petesilver 16:00 17 Feb 16

Have already tried all those but no luck !!!!!

  Fruit Bat /\0/\ 16:16 17 Feb 16

Right click the start button and select "Run" and type services.msc

Find "Background Intelligent Transfer Services" and check that it is Started and Running, if not right click it and choose Start.

if still no working try:

  1. Right click Start and then select “Command Prompt (Admin)” from the menu.

  2. Stop the BITS, Cryptographic, MSI Installer and the Windows Update Services. by typing the following commands. Press “ENTER” after each command.

net stop wuauserv

net stop cryptSvc

net stop bits

net stop msiserver

  1. Rename the SoftwareDistribution and Catroot2 folder by typing the following commands. Press the “ENTER” after each command.

ren C:\Windows\SoftwareDistribution SoftwareDistribution.old

ren C:\Windows\System32\catroot2 Catroot2.old

  1. Restart the BITS, Cryptographic, MSI Installer and Windows Update Services by typing the following commands in the Command Prompt Press the ENTER after each command.

net start wuauserv

net start cryptSvc

net start bits

net start msiserver

  1. Type Exit to close Command Prompt and then restart the computer.
  Petesilver 15:01 19 Feb 16

Hello Fruit Bat I have been thru the above but I'm still not sure what I have done as net stop wuauserv............gave me a message the it could not be stopped both renaming entries......gave a message I could not do it anyway I had a second try and then net stop msiserver................said is not started

anyway after a reboot it seem the update is now working and actually installed one. and I see all the History of installations had disappeared I assume this is due to renaming in some way, I just wish I knew. Still thanks again Peter

  Petesilver 15:18 19 Feb 16

just another thing is I ran the Windows Fixit app and I still get "service registration is missing or corrupt"

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Best Design, Illustration, Animation and VFX Awards of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced