WD External Hard Drive

  4wildlife 14:40 30 Jan 10
Locked

l purchased a WD 650gb external hard drive a while ago, l've had no problems with it, so l bought another WD 1tb to use as an extra backup for my pics as l take alot of photo's. When l have the 1tb plugged in and then l turn my computer on it runs so slow it nearly stops/freezes, it is so bad that l can't use the computer,l have to unplug the hard drive turn the computer off then on again for it to work properly. l got in touch with WD who told me to do an RMA, they replaced it with no explanation and a completely different hard drive, (l had an elements they replaced it with the book) this one does exactly the same, does anyone have a solution as WD will not answer my emails. Can anyone recomend a good external hard drive. Thanks

  rdave13 17:15 30 Jan 10

When I need to use an external HDD for backup it's never connected to a usb port when booting up PC.
After booting, and logged in, I connect the usb connection of the external HDD and then power up if it has a power adapter.
Windows then brings up the 'new hardware' icon and have had no problems. I also use this icon to 'eject' or 'remove' the HDD when no longer needed.
Possibly worth trying and not booting up with the drive connected to usb.

  4wildlife 17:33 30 Jan 10

Yes!! it works fine if l plug in the hard drive after l have started my computer, Thank you very much for your help.

This thread is now locked and can not be replied to.

Huawei P10 review

1995-2015: How technology has changed the world in 20 years

How VR is being used to simulate space

New iPad, iPhone SE & Red iPhone 7 on sale now