Vista SP2 stops recognition of wireless card

  ce79 04 Jun 09
Locked

On installing SP2, after the reboot my wireless network adaptor is no longer recognised.

In Network Diagnostics etc the network card cannot be found, let alone fixed! However, in Device Manager it is apparently working fine.

Further reboots didn't fix.
The only solution was to use System Restore to get rid of SP2. Instantly on reboot all was happy :-)

I guess I can live happily without SP2 for the moment, but wondered if anyone else has had a similar problem, or has a solution?
Dell Inspiron 1525, running Avast antivirus, with Intel PRO 3945/ABG wireless card.

  Ashrich 04 Jun 09

Go to the Intel site and download the very latest drivers for the card .


Ashley

  mooly 05 Jun 09

I found after SP2 that it took ages to connect, about 2 to 3 mins, even after several starts.
Fixed mine by right clicking the wireless icon and selecting "diagnose and repair". It found no fault but offered to send report, I accepted. and it's been perfect ever since.

  sunnystaines 05 Jun 09

I have the same intel wifi and found a new updated driver click here

  sunnystaines 05 Jun 09

intel link

click here

  ce79 06 Jun 09

Thanks for your replies - Diagnose and Repair did nothing at all with mine. However I have found a newer driver (from 11.1.1.3 to 12.4.0.0) and will see how that goes!

  ce79 07 Jun 09

Got the latest Intel driver, re-installed SP2 and still have exactly the same wireless card issue.
According to the Intel diagnostic tool, the card is "disabled or not present", but according to Device Manager it is working normally. The Windows 'Diagnose and Repair' can't fix it.
Any further thoughts? Thanks!

  sunnystaines 08 Jun 09

have you tried the dell helpline?

  ce79 10 Jun 09

I've emailed but heard nothing back yet. Will phone when I get some free moments in the daytime, and let you know where I get to.

  sunnystaines 11 Jun 09

if its not a rip off 09 number give them a ring, if its like sony support they never reply I still waiting a reply since dec08 despite chase ups.

  ce79 15 Jun 09

Spent an hour on phone with Dell guy, who recommended BIOS update. We actually did that while I was on phone - it hasn't fixed it.
In the end (after a lot of other fiddling around) he said it was a Windows problem and there was nothing more he could do.
So I am now rolled back to pre-SP2 again and biding my time!
I wonder whether re-installing SP2 *on top of* the BIOS update (rather than the other way round) might help. Does it sound worth the bother?!
I will also keep installing other Windows Updates and see whether anything else makes it worse (or better).
Thanks for all your help so far, do let me know if inspiration strikes.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message