Vista Service Pack 2 Won't Install

  blackrook 08:11 AM 16 Apr 11
Locked

When I try to install Windows Vista Service Pack 2 the error message 0x800f900 appears straight after accepting the licence.

I spent most of yesterday looking through Microsoft support and various forums and I have now tried the stand alone download...the system update readiness tool...disabling anti-virus, malware and firewall... and using the system file checker tool to check there are no integrity violations.

I don’t want to give up, because I suppose that the lack of SP2 will just become a bigger problem as time goes on (essential for IE9, for example), so I would really appreciate some advice on how to fix the problem.

(My machine is a Dell XPS 420 with Vista Ultimate 32 bit and all the other updates, including SP1.)

  blackrook 12:27 PM 16 Apr 11

I ran the tool. It didn't flag any problems, but I did not check the log. Is this important? The link you gave mentions the location of the log, but I do not know how to get to a "location". Perhaps you can advise how to do this and I what I would do then.

Advertisement

This thread is now locked and can not be replied to.

How to watch EA Gamescom 2015 Press Conference live: EA Gamescom live stream - watch EA talk Star…

1995-2015: How technology has changed the world in 20 years

Play the retro 8-bit dating naked adventure game by The Uprising Creative

From Antennagate to Yellowgate: The 10 worst Apple scandals (and why they were blown out of proport)…