Vista is actually quite good!!!

  darrenrichie 12:22 31 Mar 08
Locked

I have been using Vista dual booting with XP home for somewhile now. After going through the threads I noticed that so many people want to post their grievances and complaints about it and it occurred to me that we need to tell everyone about our good experiences with it.
I think it is obvious that new OS's are going to have problems because we all have different set ups and PC's and we all expect to install a new OS and for it to work straight away, with no problems and for it to be better than our "tweaked over a few yeras" XP systems.
I use Vista more than XP because it works so well and I have hardly any problems. If I have a problem I can research it and sort it out. It seems to me that alot of people want to bitch and moan about a problem Vista may have but not actually put the effort in to resolve the problem themselves. Yes I know not everyone may be comfortable or tech-savvy enough to do this but those people seem to accept that and request help.
I want to say that Vista is working great for me with SP1 installed and if someone was to ask me if it was worth getting it pre-installed I would say "yes" and enourage those who have ditched it after 1 week of trying it, to go back to it and give it a chance.

  Covergirl 12:54 31 Mar 08

My Vista Home Premium seems to be going well after 5 months of abuse.

Still boots up fast and doesn't crash at all.

I bought an Acer T180 5000 box with 2GB Ram from Comet.

It also goes a lot faster (I think) without the preloaded Acer crap - Norton Internet Protector, and a few bits and pieces serving no useful purpose were removed.

Installed AVG, use Windows Firewall, Webcam, 8 PC Games, webcam, Wireless dongle, various camera software, various music/MP3 software - the list goes on and it's still stable.

I use CC Cleaner weekly to remove internet crap and registry errors.
I also run a regular full system scan using AVG.
Defragged a few times . . . . and still stable !

  pchelper001 13:15 31 Mar 08

i have had no problems with it at all...and i find it a lot easier to use than xp.

  peter99co 13:32 31 Mar 08

Have you tried the defrag in vista set to run in auto? After a period of time the drive fragmentation is almost non-existant I believe.

  belfman 14:20 31 Mar 08

I have recurrent (at least once a day) of IE7 stopping responding and having to be restarted. This has happened for a while now.

Part from that VistaHP SP1 is very stable.

  J B 15:52 31 Mar 08

Vista runs just fine on my HP Notebook and I don't have SP1 installed, and I am not worried about it either. The machine is bang up to date and still nothing. My guess is that SP1 doesn't like HP Notebooks whatever their guise. J.B.

  Ashrich 18:30 31 Mar 08

Vista SP1 probably doesn't like your soundcard drivers and won't upgrade until the makers provide updated ones , although one of the makers has now gone out of business and the new owners aren't too keen on providing updates ( Sigma Tel )


Ashley

  Covergirl 08:44 01 Apr 08

Peter99co
Sounds like it defrags for about 5 minutes after boot up. Runs OK though, no apparent performance lag.

I haven't tried setting up Defrag to run in Auto. I like to control it. I like to remove all temp files, internet cache and recycle bin before it runs - that must help I'm sure. Same for AVG System Scan.

  peter99co 09:30 01 Apr 08

I think Vista defrag is a background operation and waits if you are active and runs again when you are clear.

XP was in your face and you could not really do anything until it had completed.

  darrenrichie 12:01 01 Apr 08

Actually my only peev is that my sound card drivers are a bit pants. It does work but I don't have any of the extras and settings that I use to set it up for recording music. It does annoy me slightly that some manufacturers haven't made more of an effort to get support for some hardware. I know alot of people blame Microsoft for this but I think alot of the blame should go to hardware/software manufacturers for not having suitable drivers/updates out quickly enough.

  Pine Man 14:34 01 Apr 08

'my sound card drivers are a bit pants'

You didn't mention your sound card provider but I wouldn't mind betting it's Creative!

I got my Vista PC just over a year ago and my sound card drivers were useless. It took about 6 months for Creative to offer 'improved' drivers that helped a bit and now SP1 is out those 'improved' drivers are preventing it from updating!!!

This thread is now locked and can not be replied to.

Sniper Elite 4 review: Headshotting Nazis has never felt so good

1995-2015: How technology has changed the world in 20 years

The Fresh New Fonts of 2017

WWDC 2017 dates: How to get WWDC 2017 tickets, when is WWDC 2017 and more details announced