Turning off auto wifi connect

  fredsboy 14:19 PM 20 Jun 13

I have windows 8 and recently one of my neighbours router has become the router of choice for my computer.Sometimes the signal from this router is nearly as strong as mine. I untick the auto connect button but it immediately returns. I have ticked not to find other wifi sources and ticked my router as the favourite but still occasionally my computer is trying to connect and drops my connection. How can I remove my neighbours router?

  fredsboy 14:31 PM 20 Jun 13

My router is a Belkin and I have changed the channel to stop any interference. My ISP is Plusnet. However I think the problem is within Windows 8 because I cannot turn off the auto connect for the other router.

  fredsboy 16:40 PM 20 Jun 13

No it is definitely the neighbours, have just checked with him. It doesn't actually connect because of the firewall but tries to and disconnects my wifi. Thanks for responding

  corollas 10:47 AM 24 Jun 13


I have what might be a similar issue. In my case, ALL my wifi connections have the 'connect automatically' option checked. If I try to uncheck these, they recheck immediately. This is recent issue...was not occuring a couple weeks ago (ie I could deselect the 'connect automatically' option and it would stay deselected).

Right clicking on each wifi connection does nothing. I can only right click on a network I'm connected to and therefore thats the only way to select the 'forget network' option.

This is not really an issue at home for me unlike the above poster since i am auto connecting to my preferred network immediately as prioriy.

But its a real issue when I'm out and about with a security risk from auto connecting to free unsecured networks without my knowledge.

I am currently discussing with MS Win 8 support to try and get a resolution...will post if manage to get a fix.

  rdave13 17:39 PM 24 Jun 13

You could try this little program, Wi-Fi Profile manager. Download is from the Windows Club, description from Lifehacker. I've not used it but worth a go I think.

  corollas 23:50 PM 24 Jun 13

I've found a 'semi-solution'.

Firstly, I installed the Intel Proset/Wireless Utility Connection (not sure if you need an Intel wireless adapter for this) then in the system tray select the ICU then set ICU so that Intel manages wireless networks rather than windows.

Next select the ICU again, select configure Wifi then goto tools menu. Select Application settings, under 'auto connect' select the 'Do not connect automatically' option.

Now if I disconnect from a network, it will not reconnect me automatically...so I am free to select whatever network I want, or none (subject to comment below about system startup)!

This will not 'uncheck' the 'connect automatically' options in the networks, but it does seem to override them after you disconnect from the network so does not reconnect.

However a couple issues:

  • When turning on my system, the computer still autoconnects to a network. However when I disconnect, it does not automatically reconnect

  • I no longer have autoconnect to my home network (not really an issue for me) except as above on system startup

Might try rdave's profile manager at some stage too.


This thread is now locked and can not be replied to.

Best Black Friday deals 2015 live blog: Best UK Black Friday weekend deals & best UK Cyber Monday…

1995-2015: How technology has changed the world in 20 years

The best Black Friday Deals for designers and artists – updated

20 Mac Power User Tricks... That You Didn't Know