trying to update ATI driver in WIN 7

  morris948 28 May 09
Locked

Hi
I am having difficulty udating my graphics card to the latest version in WIN 7.
(Ver 9-3_Vista32_Win7_32-dd_ccc_wdm_enu.exe)

I have a ATI saphire X1650 pro 512Mb ddr card, and every time i try to run the installer, i get a log file report that says the driver installed does not match the device ( see below report).


I use the same PC for win XP when plugging in the hard drive for each OS, and i updated the XP hard drive with the same version for XP,
(Ver 9-3_Xp32_dd_ccc_wdm_enu.exe) and this updated just fine.

Can anyone see what is going wrong by looking at this report:-

Catalyst® Install Manager
Installation Report
05/28/09 13:58:28

Hardware information
Name ATI Radeon Graphics Processor
Manufacturer ATI Technologies Inc
Device ID 0x71c1
Vendor ID 0x1002
Class Code 0x030000
Revision ID 0x9e
Subsystem ID 0x0850
Subsystem vendor ID 0x174b
Other hardware
Existing packages
Microsoft Visual C++ 2005 SP1 Redistributable
Packages for install
Catalyst Control Center
Final Status: Success
Version of Item: 2009.0225.1546.28221
Size: 150 Mbytes
ATI Catalyst Install Manager
Final Status: Success
Version of Item: 3.0.715.0
Size: 20 Mbytes
ATI Display Driver
Final Status: Fail
Version of Item: 8.591.0.0000
Size: 90 Mbytes

Other detected devices
ATI Radeon Graphics Processor
Manufacturer ATI Technologies Inc
Device ID 0x71e1
Vendor ID 0x1002
Class Code 0x038000
Revision ID 0x9e
Subsystem ID 0x0851
Subsystem vendor ID 0x174b
ATI Radeon Graphics Processor
Manufacturer ATI Technologies Inc
Device ID 0x71c1
Vendor ID 0x1002
Class Code 0x030000
Revision ID 0x9e
Subsystem ID 0x0850
Subsystem vendor ID 0x174b
ATI Radeon Graphics Processor
Manufacturer ATI Technologies Inc
Device ID 0x71e1
Vendor ID 0x1002
Class Code 0x038000
Revision ID 0x9e
Subsystem ID 0x0851
Subsystem vendor ID 0x174b

Error messages
Driver Install: the specified driver package was not installed for matching devices

  laurie53 28 May 09

I had a minor problem with ATI too.

Try reinstalling from the original disc and then updating from the website.

Also had the dreaded yellow exclamation mark in Device Manager until latest Win 7 update was installed.

  morris948 28 May 09

i will try try this again.

But i dont have any yellow exclamation mark in device manager, i am trying to fix the BSOD that plagues my system when using WIN 7, and this driver looks like the reason for it.

BSOD message is always - 'Driver IRQL less than or equal to zero' it can happen randomly at any time.

Unfortunantly, i cant read the whole script fast enough before it reboots, unless someone knows a way to halt this process.

  Strawballs 28 May 09

You are downloading the drivers for Vista not XP I think Win 7 is to Vista what SP2 was to XP but they changed the name as so much bad publicity with Vista

  morris948 29 May 09

I did try and download the XP driver to the WIN 7, but i got an ATI message telling me that the XP driver is incompatible with WIN 7.
The Vista driver did load up the control centre as shown but the display driver failed.

The ATI web site does not have a WIN 7 driver for the X1650, they all seem to start from HD3000 & above.

  Strawballs 29 May 09

The Vista one should work with Win7 My Nvidia ones came up with a message "failed to install properlly install using correct settings" so I clicked on that and it worked fine after that and the same happened for my Epson DX4400 printer.

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message