My recycle bin does not keep deleted files.

  Errabond 19 Nov 11
Locked

My recycle bin does no longer retain deleted files and every time I delete a file it gives the warning that the file will be permanently deleted. Custom size of the recycle bin is 16375 MB; the option: don't move files to the recycle bin, remove files immediately when deleted is unticked; the option: display delete confirmation is ticked. This malfunction started after I downloaded a set of Windows7 updates. In the recycle bin there are still 3 files I had deleted as usual before the updating. I tried to go back to a restore point made before the updating but all the same the recycle bin does not keep newly deleted files. What can I do? I would very grateful if anybody could help

  john bunyan 19 Nov 11

Althoug a slightly different problem, this link shows how to restore a corrupted recycle bin:: http://www.vistax64.com/tutorials/131294-recycle-bin-corrupted-cannot-delete-file-folder.html

  difarn 19 Nov 11

Hi

It may be that the recycle bin has been corrupted somehow. I came across this piece of advice:-

It could be possible that the recycle bin is corrupted. Follow these steps to fix it.

The steps below automatically creates a new clean Recycle Bin that will work properly again.

Note: This will permanently delete all files in the Recycle Bin for all user accounts on the computer.

a. Go to start and type “cmd” without the quotes.

b. Right-click on cmd and select “Run as administrator”. This opens elevated command prompt.

c. In the elevated command prompt, type “rd /s /q C:\$Recycle.bin” without the quotes and press Enter.

NOTE: For the other hard drive letters, substitute C: for the other hard drive letter instead. For example: rd /s /q E:\$Recycle.bin

d. Close command prompt window.

e. Right click on an empty area of the desktop and click on Refresh.

f. The Recycle Bin should be empty now. If not, then repeat these steps for any other hard drive letter that you have.

Test the behaviour of Recycle bin to verify if the issue is fixed.

  johnathann 21 Nov 11

Right-click Recycle bin & check to make sure the following option.

"Do not move files to the Recycle Bin, Remove files immediately when deleted " is not checked.

  iboard 22 Nov 11

Not completely on topic but i think a smart thing to do..

Just to be save, find yourself some file recovery software and install it already.

If you accidentally delete a file and your recycle bin problem causes you not to be able to restore it again than you will save yourself a lot of problems/discomfort having the right software available already (and because already installed you will not risk overwriting your files when needing to download and install after you deleting files).

There are many good file recovery products out there.. Just do a quick search or go to www.download.com. I like to use the one from auslogics. They got a free trial of (i thought) 14 days. This should give you the time to solve your recycle bin problem. And not risk permanently deleting important files. You can find it here.

  jackdouglas7 05 Jan 12

Hi, Ive a similar problem but mind is due to adding another hard drive. The hard drive was from my old pc so I thought that rather than moving all my music and pics I would just put my old hard drive into the my new PC. It even has a draw on the case specifically for this. As soon as I put it in I stopped seeing items in my recycle Bin although they were there. When I took it out I could see them again. Does any one know what I can do about this ? Many thanks

Advertisement

This thread is now locked and can not be replied to.

Should I upgrade to Windows 10? 8 reasons why you should upgrade to Windows 10... and 2 why you…

We are being sold the ability to spend money we don't have. And we love it

IKinema aims to banish droopy shoulders and wonky spines in animated CG characters

How to use Apple Music in the UK: Complete guide to Apple Music's features

We use cookies to provide you with a better experience. If you continue to use this site, we'll assume you're happy with this. Alternatively, click here to find out how to manage these cookies

hide cookie message