Issue with faulty USB ports

  trisha01 12:54 25 Aug 14
Locked

My Acer desktop pc has 3 usb ports at the front and 4 at the back of the tower. over recent weeks when anything is plugged into the front, I get constant connect/disconnect sounds, as the pc is quite old now I put this down to age and that the ports no longer had a snug fit and I did use the front ports quite often.

I bought a four hub usb connector and plugged this into one of the rear ports. Now whenever I plug in a usb stick or the mobile phone or tablet am still getting the disconnect/connect sounds, it's like it's cutting out, however, can't be the ports because I have a usb mouse and keyboard plugged into the back and have no problems with them. The back ports are not used due to access. I've checked in device drivers and uninstalled the drivers and reloaded them, any ideas?

  rdave13 18:36 25 Aug 14

Is the USB hub a powered one? If not you might get the same problem if the old PSU can't supply the power.

  nickf 18:53 25 Aug 14

May also be something as simple as cable has worked loose on motherboard . Always worth double checking .

This thread is now locked and can not be replied to.

Nintendo Switch review: Hands-on with the intuitive modular console and its disappointing games…

1995-2015: How technology has changed the world in 20 years

The updated 'Corel Painter inside Photoshop' plugin ParticleShop offers new brushes

Best running headphones | Best sport & fitness headphones: 4 brilliant pairs of wireless…